LinuxCNC with Triplebeast, motors won't run

More
12 Oct 2017 15:12 #100274 by Wailem
Wailem created the topic: LinuxCNC with Triplebeast, motors won't run
Hello,

A time ago the computer attached to our ISEL gantry mill has crashed.
We placed a new hard drive inside and I installed Ubuntu Precise 12.04 x86 with LinuxCNC 2.7. (I do not know the previous version of LinuxCNC or Ubuntu we used).
De configuration had the name ISEL, so I made a sample configuration ISEL and overwrite it with the backup files.

After starting LinuxCNC, I get the message something wrong with ‘loadrt probe_parport ‘’, so I remove this line from the .hal file.
Then I started LinuxCNC again, everything looks the same to me, I get this error: ‘RTAPI: ERROR: Unexpected realtime delay on task 1’.

When I home and hold some metal in front of the inductive home switches, LinuxCNC will recognize them. So there is some connection…
When I connect the computer to another CNC-machine and use the same configuration, the motors turn! So it is not the computer…

The ISEL machine uses a Triplebeast, so I think it has to do something with that. I have tried a lot of thing and search all over the internet, but still no result.

I have checked the files from the new configuration and the backup and find some difference, I find two things, but I do not know what to do with it.
- In the .stepconf file are some differences, but at line 39 something is manually added. Could this be it?
- The backup has a folder inside named ‘stepper’ inside; can this folder have any influence on the ISEL?

Or could it be something else?

I have added a .zip file with the backup and the new configuration.
Hope someone can help with this problem, I do not know what to do….

Thank you!

File Attachment:

File Name: LinuxISEL.zip
File Size:27 KB
Attachments:
More
13 Oct 2017 12:53 #100323 by andypugh
andypugh replied the topic: LinuxCNC with Triplebeast, motors won't run

Wailem wrote: After starting LinuxCNC, I get the message something wrong with ‘loadrt probe_parport ‘’, so I remove this line from the .hal file.

This is the correct fix, 2.7 removed the need for probe_parport,


Then I started LinuxCNC again, everything looks the same to me, I get this error: ‘RTAPI: ERROR: Unexpected realtime delay on task 1’.

That isn't ideal, but is not the cause of your problem.


When I home and hold some metal in front of the inductive home switches, LinuxCNC will recognize them. So there is some connection…

Good test, that shows that the parallel port connection is correct and that realtime is running.

The ISEL machine uses a Triplebeast, so I think it has to do something with that. I have tried a lot of thing and search all over the internet, but still no result.

This sounds like a "enable" problem. Are the motors locked or free to move when LinuxCNC is out of e-stop and turned on?
More
13 Oct 2017 15:59 #100326 by Wailem
Wailem replied the topic: LinuxCNC with Triplebeast, motors won't run
Andypugh,

Thank you for the reply!

I will not be at work till Monday, but normally the motors were locked in that situation.
So you think the motor get pulses, but cannot move because they are locked?
If it is the problem, how can it be fixed?
More
13 Oct 2017 17:01 #100327 by andypugh
andypugh replied the topic: LinuxCNC with Triplebeast, motors won't run
No, I would normally expect quite the opposite. If the drives are not enabled then the motors are free to turn.
If the motors are locked then the drive is supplying current to the windings, so is enabled, but it isn't changing the excitation pattern to cause the motors to move.

Looking at the config you have a base period of 4166nS and a step-length setting of 1nS. However the system can't do a 1nS step, so you will end up with a single base-thread pulse of about 4.2uS.

I have to say, that seems a bit optimistic. Try 20,000 nS base thread period. (in the INI)

(typically a step-length of 1 is used when using the parallel port "reset" function which allows you to make one step per thread rather than one every other thread.

The Triple Beast manual says that it needs a 2uS step time, so it would appear that things should be OK, but just as a test it would be worth editing the HAL file to set the step length to 5000.
More
17 Oct 2017 07:42 #100458 by Wailem
Wailem replied the topic: LinuxCNC with Triplebeast, motors won't run
It is working now!
I have changed the base thread period to the 20 000 nS, now all motors run like they used to be.

Thanks for the info!
Time to create page: 0.077 seconds
Powered by Kunena Forum