Keyboard auto repeat fouling jogging in my custom build

More
15 May 2017 21:56 #93242 by siggi
siggi created the topic: Keyboard auto repeat fouling jogging in my custom build
Hey y'all,

I have a local run-in-place build of 2.7.8 running on an "4.9.4-rt2 #1 SMP PREEMPT RT" x64 kernel, on an Ubuntu 16.04 distro. I have a Mesa 5i25/7i76 control system I'm wiring up slowly to my Taig MicroMill DSLS3000 control box.

This is overall working like a charm, except for this vexing issue that it appears keyboard auto-repeat is messing with jogging. What happens is that for the first little bit, jogging works just fine, accelerates to speed and runs smoothly. Then after a "little bit" the motor starts spasming and spitting, and when I let go of the key, the jogging keeps going for a bit.

I'm sure there's a quick and easy fix for this somewhere, but I'm not sure where to start.
Is there X configuration someplace to kill autorepeat for axis, or some such?

Siggi
More
16 May 2017 19:48 #93277 by siggi
siggi replied the topic: Keyboard auto repeat fouling jogging in my custom build
This is definitely keyboard auto-repeat. If I do

> setx r off

the jogging works like a charm, but now I have no keyboard repeat in that X session.

Siggi
More
17 May 2017 21:49 #93317 by andypugh
andypugh replied the topic: Keyboard auto repeat fouling jogging in my custom build
I don't know what the problem is, but it's not a common problem. In fact I have never heard of it before.
So, I think the starting point of the investigation has to be to wonder how your setup is different from all other ones.

(or, perhaps add a jogwheel or joystick instead...)
Time to create page: 0.058 seconds
Powered by Kunena Forum