classicladder will not load change signals

06 Jan 2017 05:18 #85324 by johnmc1
Good Day All,
I am trying to convert a old mazak M3 lathe to Linuxcnc and mesa cards 5i20,7i33TA,7i37TA.
Problem I can not load the tool change signals ,
The axis GUI file shows the classicladder logic but all IO variables have no hal signals connected.
If I add the tool change signals the system will not configure .
where are all the files related to classicladder located ,custom hal, ini,?

Any help or direction will be greatly appreciated

Best Regards john
Linuxcnc error report

Real time system did not load

Debug File information

Error : could not insert module /usr/realtime-3.4-9rtai-686-pae/modules/rtai_hal.ko:file exists

Attached Hal,clp and Ini files
17 Jan 2017 12:40 #85909 by andypugh
Did you get to the bottom of this?

/rtai_hal.ko:file exists

Can often mean that a failed launch has let things in a tangle and a re-start is needed.
20 Jan 2017 10:49 #86236 by johnmc1
Good day Andy,
Thanks for the interest .
I have not solved the problem with loading classic ladder,
I have tried restarting but no progress as yet,
Regards john
20 Jan 2017 19:09 #86274 by cmorley
Can you post more of the error messages? all of your config files?
Also there is at least one spelling mistake in your HAL file haliu instead of halui.
I'm sure this isn't the actual problem but needs to be fixed.
This is a pncconf built config.... did it work before you added to it?

Chris M
23 Jan 2017 09:02 #86461 by johnmc1
Good Day Chris,
Many thanks for your reply,
The pncconf built config worked ok, the problem started when I tried to load the tool change classicladder.
The config will only install when all the machine IO's are commented out, at present one of the machine IO's is not
commented out in the in the custom.hal file, this is stopping linuxcnc config from starting.
I have not been able to copy the Print file information or the Debug file information (do not know how).
I have copied linuxcnc error message which is included in the attached file

File Attachment:

File Name:
File Size:50 KB
My linux ability is very limited but trying to improve.
Any advise is most welcome.
Regards john
23 Jan 2017 14:32 #86483 by Todd Zuercher
I think that some of the pin names in your custom.hal file are wrong.
for example:
hm2_5i20.0.gpio.071-out should be hm2_5i20.0.gpio.071.out
24 Jan 2017 03:16 #86532 by cmorley
If you open a terminal, run linuxcnc from there (type linuxcnc and press enter).
it should print error messages. copy and paste them here please.

Chris M
24 Jan 2017 07:15 #86537 by johnmc1
Good Day Chris.

Error messages when starting linuxcnc from the terminal,
linuxcnc_debug.txt , linuxcnc_print.txt

Regards john

File Attachment:

File Name: linuxcnc_print.txt
File Size:1 KB

File Attachment:

File Name: linuxcnc_print.txt
File Size:1 KB
25 Jan 2017 04:55 #86593 by cmorley
There is no linuxcnc_debug.txt file (they are both the same ) :)

To be clear I'm looking for the text printed in the terminal.

Chris M
25 Jan 2017 05:00 #86594 by Todd Zuercher
Did you fix the pin name problems in the custom.hal file?
Time to create page: 0.187 seconds
Powered by Kunena Forum