Spindle configuration

More
16 Mar 2017 13:20 #89739 by Nondepietjes
Nondepietjes created the topic: Spindle configuration
Hi,

I'm trying to configure my spindle for lathe machine.
I have a encoder and feedback with tacho.
Can somebody take a look at my hal.file?


much appreciated

File Attachment:

File Name: MD5_IT_2017-03-16.hal
File Size:11 KB

File Attachment:

File Name: MD5_IT_2017-03-16.ini
File Size:3 KB
Attachments:
More
16 Mar 2017 14:34 #89742 by comjon
comjon replied the topic: Spindle configuration
You are looking to set S commands on your spindle, to do thread cutting, for example?
More
16 Mar 2017 14:41 #89743 by Nondepietjes
Nondepietjes replied the topic: Spindle configuration
yes, and if my hal file is correct. is everything is connected
More
16 Mar 2017 15:20 #89747 by comjon
comjon replied the topic: Spindle configuration
I am not at my machine right now, but I think there may be a lathe sample configuration with spindle encoding in the sim folder on LinuxCNC startup.
More
16 Mar 2017 18:07 #89760 by Nondepietjes
Nondepietjes replied the topic: Spindle configuration
I have tested the hal file, but it appears that my spindle-enable is not connected in my hal file.
Can somebody explain me what i'm doing wrong?

many thanks
More
16 Mar 2017 19:38 #89777 by andypugh
andypugh replied the topic: Spindle configuration
Is your spindle enable physical wiring corrected to the spinena pin, ro to separate GPIO?

I see


# external output signals
...
# --- SPINDLE-ON ---
#net spindle-on hm2_5i25.0.7i77.0.0.output-09

Which makes me wonder.

(But nothing drives that spindle-on signal, you should probably delete that commented-out line)
More
17 Mar 2017 07:56 #89801 by Nondepietjes
Nondepietjes replied the topic: Spindle configuration
Normaly my wiring is correct, i checked it a few times.

i'm working with a mesa 7i77 card and connected my whires to Drive5.

So i have to connect the spindle-on to my spinena pin?
More
17 Mar 2017 08:43 #89803 by andypugh
andypugh replied the topic: Spindle configuration

Nondepietjes wrote: So i have to connect the spindle-on to my spinena pin?


Not necessarily, there is a spindle-enable signal that seems to be connected to the right things.

Can you show us a diagram of the wiring to TB5 21, 22, 23, 24 ?
More
17 Mar 2017 12:43 #89818 by Nondepietjes
Nondepietjes replied the topic: Spindle configuration
My RF signal is connected to the ENA- signal. ENA+ is connected to powersupply.
GRD and ANOUT to the amplifier signals
More
17 Mar 2017 12:54 #89819 by andypugh
andypugh replied the topic: Spindle configuration

Nondepietjes wrote: My RF signal is connected to the ENA- signal. ENA+ is connected to powersupply.
GRD and ANOUT to the amplifier signals


Is that what the spindle drive needs? Often the drive enable needs to connect the enable output to the drive common.

What is the spindle drive?
Time to create page: 0.080 seconds
Powered by Kunena Forum