Spindle configuration

More
20 Mar 2017 15:19 #89950 by Nondepietjes
Nondepietjes replied the topic: Spindle configuration
Yes, that of the RF. Disable led.

in my hal.file my spindle-on isn't connected. to witch pin should i connect it?

File Attachment:

File Name: MD5_IT_2017-03-20.hal
File Size:11 KB

File Attachment:

File Name: MD5_IT_2017-03-20.ini
File Size:3 KB
Attachments:
More
20 Mar 2017 15:30 #89951 by andypugh
andypugh replied the topic: Spindle configuration
spindle-on in your HAL is created but not used. Just delete it.
It looks to be left over from a previous config or edit or something.

Your drive seems to have two separate enable inputs, Ready-for-operation and Controller-ready.
Try connecting one to the halui.machine.is-on HAL pin.
More
20 Mar 2017 15:40 - 20 Mar 2017 15:40 #89952 by Nondepietjes
Nondepietjes replied the topic: Spindle configuration
Can you give some tips or an example?

So i don't have to connect extra cables? I'm searching a long time on this and i'm totaly lost ;p
Last Edit: 20 Mar 2017 15:40 by Nondepietjes.
More
20 Mar 2017 19:03 #89961 by andypugh
andypugh replied the topic: Spindle configuration

Nondepietjes wrote: Can you give some tips or an example?

So i don't have to connect extra cables? I'm searching a long time on this and i'm totaly lost ;p


No, I think you do need to connect extra cables, and one of the cables needs to be controlled from HAL by halui.machine.is-on (or any other pin that you want to use, like axis.0.amd-enable-out)
The following user(s) said Thank You: Nondepietjes
More
20 Mar 2017 21:05 #89967 by tommylight
tommylight replied the topic: Spindle configuration
Sorry to intervene, but:
axis.0.amd-enable-out
Should be
axis.0.cmd-enable-out
The following user(s) said Thank You: Nondepietjes
More
20 Mar 2017 23:09 #89976 by andypugh
andypugh replied the topic: Spindle configuration

tommylight wrote: Sorry to intervene, but:
axis.0.amd-enable-out
Should be
axis.0.cmd-enable-out


Actually, I was trying for amp-enable-out, but mis-typing from memory.
The following user(s) said Thank You: Nondepietjes
More
21 Mar 2017 07:06 #89984 by Nondepietjes
Nondepietjes replied the topic: Spindle configuration
Thank you for the explenation. i will let know how it went
More
22 Mar 2017 08:25 #90048 by Nondepietjes
Nondepietjes replied the topic: Spindle configuration
Hi,

I don't find the right connections on my panel. i have not enough information about my panel.
Maby does someone know more about this panel?
Here are some pictures from my X2 panel.

Attachments:
More
22 Mar 2017 09:29 #90051 by andypugh
andypugh replied the topic: Spindle configuration
The PCB has screen-printed legends on it, those are almost certain to be consistent with the description of the other panels in the documentation.
So, it should be possible to work out what each terminal is for from the screen-print and the manual.
More
22 Mar 2017 10:34 #90055 by Nondepietjes
Nondepietjes replied the topic: Spindle configuration
i know thate the black, white, brown and green wire are going to the tacho of the motor. the blue whire on the left, number one is a ground. al the other whires i didn't find. and in the manual that is available is alsow nothing to find.

Attachments:
Time to create page: 0.148 seconds
Powered by Kunena Forum