Mesa 7i76e-spindle speed variable via spindle override but not via G-code / M

More
20 Mar 2017 00:31 - 20 Mar 2017 02:48 #89913 by cut2cut
I am new to LinuxCNC ( edit : version 2.7.8 ) and Mesa hardware. ( edit : in a post further down are my HAL and INI files )

I have all three axis working on my mill but so far the spindle speed is only variable when using the spindle override slider. However, my issue is when I use G-Code and M-code they both spin the spindle motor at 100% without regard to my commanded slower speed ( i.e. : M3 S200 ).

Hopeful someone can help me figure this out before I burn out the bearings in my spindle.

Currently I should be using only 40% of maximum speed because the bearing can only handle about 3500 rpm. I'll look into changing my VFD HZ to limit the speed.. but that won't solve the issue !

Thanks in advance !

Jake
Last Edit: 20 Mar 2017 02:48 by cut2cut.
More
20 Mar 2017 00:42 #89914 by cmorley
can you post your config files please. and what version of linuxcnc are you using?

Chris M
More
20 Mar 2017 00:46 #89915 by cut2cut
I'm using LinuxCNC 2.7.8 on Mint 18.1.

Not sure where the config files are located, but I'll look around for them. I suppose the address of the files are described in the linuxcnc documentation... ? HAL and INI ?
More
20 Mar 2017 01:07 #89916 by cut2cut
Here we go , I think :

File Attachment:

File Name: my_LinuxCN...2017.hal
File Size:11 KB

File Attachment:

File Name: my_LinuxCN...2017.ini
File Size:4 KB

File Attachment:

File Name: my_LinuxCN....pncconf
File Size:308 KB
Attachments:
More
20 Mar 2017 03:11 #89922 by PCW
Try changing this:

#********************
# Spindle
#********************
[SPINDLE_9]
P = 0.0
I = 0.0
D = 0.0
FF0 = 1.0
FF1 = 0.0
FF2 = 0.0
BIAS = 0.0
DEADBAND = 0.0
MAX_OUTPUT = 7000.0
OUTPUT_SCALE = 1
OUTPUT_MIN_LIMIT = 0
OUTPUT_MAX_LIMIT = 1

To this:

#********************
# Spindle
#********************
[SPINDLE_9]
P = 0.0
I = 0.0
D = 0.0
FF0 = 1.0
FF1 = 0.0
FF2 = 0.0
BIAS = 0.0
DEADBAND = 0.0
MAX_OUTPUT = 7000.0
OUTPUT_SCALE = 7000
OUTPUT_MIN_LIMIT = 0
OUTPUT_MAX_LIMIT = 7000
More
20 Mar 2017 04:14 - 20 Mar 2017 04:17 #89924 by cut2cut
PCW,

Thanks but that didn't work. After I made that change all I hear is the relay clicking in both the spindle override and M commands too ( m3 and m4 Sxxx ).
Interestingly when I remove the check mark next to "Range 2 max RPM I have similar results ( no motor rotation from the motor at all ) but I believe the relay clicks the same way.
I have also enclosed a picture of a dialogue that comes up when I first open PnCConf stating I its using the firmware on the card because it isn't seeing hostmot2 in the lib/firmware/hm2 folder. Also is a picture of my gear / pulley settings. More importantly, possibly, I've enclosed the schematic of how my relays are wired to the 7i76e and Delta VFD-e.

( note, I changed my rpm settings to 3500 from 7000 because I changed the HZ from 120 to 60 in my VFD )
Attachments:
Last Edit: 20 Mar 2017 04:17 by cut2cut.
More
20 Mar 2017 06:47 #89925 by cmorley
Since you seem not to be using two ranges, please try with only one range selected.
Let us know if that works.

Looks like a bug in pncconf with two ranges.
(The scale ratio that Peter pointed out is wrong and so is the scaling for ranges in the main HAL file.)

Chris M
More
20 Mar 2017 06:58 - 20 Mar 2017 07:01 #89926 by cut2cut

cmorley wrote: Since you seem not to be using two ranges, please try with only one range selected.
Let us know if that works.

Looks like a bug in pncconf with two ranges.
(The scale ratio that Peter pointed out is wrong and so is the scaling for ranges in the main HAL file.)

Chris M


I actually have tried using only range one ( its selected by default ) by unchecking range #2. When I do this the spindle doesn't spin while using the spindle override slider and everywhere else. I just hear the relay click ( not 100% sure it even clicks but sure it doesn't spin ).

So should the scale ratio be 2 ( as in, 2 to 1 ) ?

Thanks,

Jake
Last Edit: 20 Mar 2017 07:01 by cut2cut.
More
20 Mar 2017 07:19 #89927 by cmorley
Oh I am starting to see the idea here I think..The original scaling in the INI was correct.
OUTPUT_SCALE = 1
OUTPUT_MIN_LIMIT = 0
OUTPUT_MAX_LIMIT = 1

meaning an input of one gives 10 volt output.
In the HAL file, requested RPM is scaled to this range 0-1
ie 3500 RPM = 1
1/3500 = .000286
so the scale gain should be the same....checking your HAL file...
More
20 Mar 2017 07:26 #89928 by cut2cut
Perhaps I first need to turn off the second range, then hand edit the scale so it won't be over written. I'll have to try it tomorrow when I'm at the mill. Gnite, and thanks for the effort Chris.

Jake
Moderators: cmorley
Time to create page: 0.291 seconds
Powered by Kunena Forum