Homing generates error

More
03 Aug 2017 16:13 #96976 by AlbertHall
AlbertHall created the topic: Homing generates error
I have a problem with homing. The home switches randomly tripped which I fixed by putting debounce in custom.hal (attached). Now jogging towards the home switches stops when the switch is hit.
I set up homing velocities and sequence in CNC3020T.ini (attached).
However, 'home all' moves the axis towards the switch and stops when the switch is hit, no backing off the switch, and shows the errors as below. How do I fix this?

File Attachment:

File Name: CNC3020T.ini
File Size:2 KB

File Attachment:

File Name: custom.hal
File Size:1 KB
Attachments:
More
03 Aug 2017 17:29 - 03 Aug 2017 17:33 #96978 by Todd Zuercher
Todd Zuercher replied the topic: Homing generates error
Add this line to each of your [AXIS_n] sections of your ini file.
HOME_IGNORE_LIMITS = YES

(Assuming you are using the limits as home switches and that they are configured as such in the hal file.)

If this still doesn't get you there you may need to show us your other hal files.
Last Edit: 03 Aug 2017 17:33 by Todd Zuercher.
More
03 Aug 2017 17:46 #96979 by AlbertHall
AlbertHall replied the topic: Homing generates error
Thanks for the reply. I tried adding that line but now it doesn't stop when it reaches the limit switch, just carries on moving up to the mechanical limit. The DRO shows the arrow when the switch is tripped.
More
03 Aug 2017 17:58 #96981 by AlbertHall
AlbertHall replied the topic: Homing generates error
Attached is the hal file.
Custom.hal attached to original post.
postgui.hal is empty.

File Attachment:

File Name: CNC3020T.hal
File Size:4 KB
Attachments:
More
03 Aug 2017 20:01 #96985 by Todd Zuercher
Todd Zuercher replied the topic: Homing generates error
Are the pins and limits you debounced the ones that you want to use for the home/limit?
If so you need also add this to your hal file "axis.N.home-sw-in" connected to the same signal as the limit switch you are using.
It would have been added automatically if you would have chosen the limit+home option for each axis in Stepconfig.
# Include your customized HAL commands here
# This file will not be overwritten when you run stepconf again

#Debounce limit switches
#load the debounce. One set of three channels. 
loadrt debounce cfg=3

#add the debounce to a thread, so that it gets run
#this is running in the fast base-thread
#you could use the servo thread. I am not sure which would be best. 
addf debounce.0 base-thread

#Unlink the parport pins and limit inputs for rewiring
delsig min-x
delsig min-y
delsig max-z

net x-raw parport.0.pin-13-in => debounce.0.0.in
net y-raw parport.0.pin-12-in => debounce.0.1.in
net z-raw parport.0.pin-15-in => debounce.0.2.in

net x-filt debounce.0.0.out =>  axis.0.neg-lim-sw-in => axis.0.home-sw-in
net y-filt debounce.0.1.out =>  axis.1.neg-lim-sw-in => axis.1.home-sw-in
net z-filt debounce.0.2.out =>  axis.2.pos-lim-sw-in => axis.2.home-sw-in

#It's important to actually activate the debounce
#20 base-threads is about 0.4mS. The typical machine doesn't move far in that time. 
setp debounce.0.delay 20
The following user(s) said Thank You: AlbertHall
More
03 Aug 2017 21:21 #96989 by AlbertHall
AlbertHall replied the topic: Homing generates error
Yup, brilliant, that fixes it, thank you very much.
Do I still need the ignore_limits lines?
More
04 Aug 2017 02:58 #96991 by Todd Zuercher
Todd Zuercher replied the topic: Homing generates error
Yes
Moderators: Rick G
Time to create page: 0.088 seconds
Powered by Kunena Forum