setting up for Parallel port Tutoral Part 3

More
26 Aug 2016 10:59 #79467 by gmouer
gmouer replied the topic: setting up for Parallel port Tutoral Part 3
Oh well. Guess that rules out a old laptop for getting acquainted with PP.
More
26 Aug 2016 12:34 #79475 by smgvbest
smgvbest replied the topic: setting up for Parallel port Tutoral Part 3
The question asked was can you run PP without a pp to look at it
forget for now about a parallel port config if all you want to do is look at PP.
You can run PP in simulator mode to take a look at PP with no hardware.

The config information I supplied is a pathpilot config.
it was already in the ~/tmc/configs/tormach_lathe/ directory and supplied by tormach.

all I did was change my config_file.txt and run operator_login.sh with the sim config and pathpilot came right up for me
my Pathpilot is running fine in simulator mode. that is all I did to take a look at PP.

if you want to run PP with a non Tormach Config then you have to do magic on the files to make them work.
More
26 Aug 2016 12:37 #79476 by cncbasher
cncbasher replied the topic: setting up for Parallel port Tutoral Part 3
if the bios has a lpt port listed , although a parallel port socket is not fitted , then it will work
or fit a pci printer port card is an option
so long as it thinks a printer port exists then it will work .
that goes for lcnc as well as pathpilot .
More
26 Aug 2016 12:51 #79477 by smgvbest
smgvbest replied the topic: setting up for Parallel port Tutoral Part 3
was your reply in reply to mine or earlier post?
I'm just saying I am running in sim mode in pathpilot, no parallel port, no mesa card. its working fine, not crashes.
More
26 Aug 2016 13:37 #79487 by gmouer
gmouer replied the topic: setting up for Parallel port Tutoral Part 3
Ok, now I go it !! Sounds like my objective is doable without much fuss at all.
More
26 Aug 2016 13:40 - 26 Aug 2016 13:42 #79488 by gmouer
gmouer replied the topic: setting up for Parallel port Tutoral Part 3

cncbasher wrote: if the bios has a lpt port listed , although a parallel port socket is not fitted , then it will work
or fit a pci printer port card is an option
so long as it thinks a printer port exists then it will work .
that goes for lcnc as well as pathpilot .


Which begs the question...
Smgvbest, does your computer have a lpt port listed in its bios screens? I realize there is no physical port.
Last Edit: 26 Aug 2016 13:42 by gmouer.
More
26 Aug 2016 14:02 #79494 by racedirector
racedirector replied the topic: setting up for Parallel port Tutoral Part 3
You can run LCNC on a virtual machine in sim mode so PP should be the same. Going to confirm tomorrow by setting up 1.9.6 under VirtualBox on my Mac
More
26 Aug 2016 14:15 #79496 by cncbasher
cncbasher replied the topic: setting up for Parallel port Tutoral Part 3
you may have problems running in a virtual machine , due to the realtime that pathpilot uses
and to the increased Latency that it produces . this goes the same for lcnc , apart from the more recent uspace variant .
More
26 Aug 2016 14:47 #79498 by smgvbest
smgvbest replied the topic: setting up for Parallel port Tutoral Part 3
It does have one listed in the bios and it is disabled in the bios
But my config is not setup to use a parallel port nor a mesa card. I'm running the simulator mode of PP/LinuxCNC
The following user(s) said Thank You: gmouer
More
28 Aug 2016 07:14 #79580 by dinkata
dinkata replied the topic: setting up for Parallel port Tutoral Part 3

cncbasher wrote: if you have problems or need help , feel welcome to shout .
also any amendments i'm happy to add .
i hope i have covered the main points clearly enough for you to follow .
.

Thank you, this works .How do I add " charge pump " ?
is it possible add ClassicLadder in PathPilot ?



Best regards .
Dinyo
Attachments:
Moderators: cncbasher
Time to create page: 0.144 seconds
Powered by Kunena Forum