PathPilot and XHC-HB04 - work?

More
13 Dec 2016 12:03 - 13 Dec 2016 12:05 #84023 by racedirector
racedirector created the topic: PathPilot and XHC-HB04 - work?
Has anyone managed to get the above pendant to work with PathPilot yet? Not having much luck at all with mine.

I thought it would be like the Shuttle Express that Tormach uses but they seem to have a piece in tmc/rtlib called milljogtranslator that converts the shuttle express stuff into whatever milljogtranslator does, all this versus the HB04 executing MDI commands.

Can anyone see if I have a snowballs chance in hell of getting this pendant running under PathPilot?

loadusr -W shuttlexpress4

loadrt milljogtranslator names=milljogtranslator
addf milljogtranslator servo-thread

# Next value NZ if buttons to latch axes
setp milljogtranslator.radio-latching 1

#
# connect shuttlexpress buttons and wheels to milljogtranslator
#
net sxp.x-button shuttlexpress4.0.button-0 => milljogtranslator.ax-butt-0
net sxp.y-button shuttlexpress4.0.button-1 => milljogtranslator.ax-butt-1
net sxp.z-button shuttlexpress4.0.button-2 => milljogtranslator.ax-butt-2
net sxp.a-button shuttlexpress4.0.button-3 => milljogtranslator.ax-butt-3
net sxp.step-button shuttlexpress4.0.button-4 => milljogtranslator.cycle-stepsizes
net sxp.spring-wheel shuttlexpress4.0.spring-wheel-s32 => milljogtranslator.ring-raw

etc etc etc


Any help would be appreciated.

Cheers
Last Edit: 13 Dec 2016 12:05 by racedirector.
More
13 Dec 2016 12:43 #84024 by cncbasher
cncbasher replied the topic: PathPilot and XHC-HB04 - work?
you need to add the xhc-04 ko file and modify the shuttle express entrys , with the xhco4 library scripts
i'm working on it .
The following user(s) said Thank You: racedirector
More
13 Dec 2016 13:20 #84026 by racedirector
racedirector replied the topic: PathPilot and XHC-HB04 - work?
Thanks Sarah

I'll give it a go and see if I can stumble upon a solution...

Cheers
More
13 Dec 2016 13:31 #84030 by cncbasher
cncbasher replied the topic: PathPilot and XHC-HB04 - work?
have you the ubuntu version of the xhc library?
you can't use the latest as it needs to be built for 10_04

if you have it working under lcnc with the xhc-04 , then copy the ini entrys across
or copy the sources of the xhc-04 to your pathpilot source , or copy the xhc-o4.ko binarys from the ubuntu version
More
14 Dec 2016 08:14 #84078 by racedirector
racedirector replied the topic: PathPilot and XHC-HB04 - work?
Yup, have the right library from Ubuntu 10.04 after finding out the newer one didn't work.

I installed Ubuntu 10.04 plus Linuxcnc to get it and had the pendant running with Axis under that. When I transferred all the relative bits to PathPilot it baulked at the MDI commands which brought me here. Images of what I have where attached.

Next I'll try modifying the shuttle express entries if I can figure them out, more homework :)
Attachments:
More
14 Dec 2016 10:11 #84081 by cncbasher
cncbasher replied the topic: PathPilot and XHC-HB04 - work?
great you managed it so far , iv'e a feeling that the mdi commands are within the python scripts
i'm just about to track them down .

any particular error your getting , email it across
More
14 Dec 2016 13:28 - 14 Dec 2016 13:28 #84087 by racedirector
racedirector replied the topic: PathPilot and XHC-HB04 - work?
Ok, progress of sorts.

Pathpilot loads without dying after I commented out the MDI commands. The pendant is (sort of) active but with that said nothing performed on the pendant triggers anything in PathPilot. However, jogging in PP changes the pendant display and zero-ing the axis in PP zeros the work display on the pendant. However, the distances are different from each other and it doesn't matter which mode I am in, G20 or G21.

It is late here now so sleep is calling but I need to figure out what connects to what now to get any further. Tomorrow is another day....
Last Edit: 14 Dec 2016 13:28 by racedirector.
More
15 Dec 2016 08:13 #84149 by racedirector
racedirector replied the topic: PathPilot and XHC-HB04 - work?
Just had a thought (dangerous I know) about the difference between PP and the pendant positional displays..... PP runs in G20 mode and converts the display to G21 as required. That may be affecting how the pendant responds to the axis positions. Will take a deeper look at this as I suss out the rest of the connection.....
More
29 Dec 2016 06:53 #84840 by racedirector
racedirector replied the topic: PathPilot and XHC-HB04 - work?
Well after persevering with this thing I now have some of the commands working. Firstly, I was a fool and finally figured out why the MDI COMMANDS weren't working..... I forgot to put the header [HALUI] in the ini file before them. Once I did that I could do a number of things with the pendant.

However there are some gotchas. PP leaves Linuxcnc in MDI more often than not meaning some part of the UI must be executed to get in into MODE_MANUAL at which time the pendant commands will work. I will attempt to investigate how to overcome this but I suspect it need a recompile of the xhc-hb04 executable, something I not comfortable with.

More investigation ans testing will be needed before I can connect this to my actual machine as I have been testing with PP in sim mode.

Any thoughts on how to keep PP in MANUAL mode would be appreciated, cncbasher maybe? :)

Cheers
More
29 Dec 2016 18:44 #84865 by cncbasher
cncbasher replied the topic: PathPilot and XHC-HB04 - work?
i'll put it on my todo list
Moderators: cncbasher
Time to create page: 0.083 seconds
Powered by Kunena Forum