Radius to end of arc differs from radius to start

More
04 Mar 2017 22:47 #89010 by Jake
I am having a bit of a challenge with this piece of code. It is a boring cycle with a 1/4" EM I have read through some of the other threads that have had a similar issue. My CAM Fusion360 was set on 4 decimal places, I did stretch it out to 5 and it is still giving me the same error. Anybody familiar enough with Fusion360 cam to know how to work through this?

Thanks!
(BORE1)
N260 M9
N265 M1
N270 T2 M6
N275 T5
N280 S8000 M3
N285 G54
N290 M7
N300 G0 X-1.875 Y-1.475
N305 G43 Z0.6 H2
N310 G0 Z0.08
N315 G1 Z0.025 F30.
N320 G18 G3 X-1.9 Z0. I-0.025 K0.
N325 G1 X-1.9125
N330 G17 G3 X-1.9375 Y-1.5 I0. J-0.025     <------Its blowing up here.  
N335 X-1.5625 Z-0.0197 I0.1875 J0.
N340 X-1.9375 Z-0.0394 I-0.1875 J0.
N345 X-1.5625 Z-0.0591 I0.1875 J0.
N350 X-1.9375 Z-0.0787 I-0.1875 J0.
N355 X-1.5625 Z-0.0984 I0.1875 J0.
N360 X-1.9375 Z-0.1181 I-0.1875 J0.
N365 X-1.5625 Z-0.1378 I0.1875 J0.
N370 X-1.9375 Z-0.1575 I-0.1875 J0.
N375 X-1.5625 Z-0.1772 I0.1875 J0.
N380 X-1.9375 Z-0.1969 I-0.1875 J0.
N385 X-1.5625 Z-0.2165 I0.1875 J0.
N390 X-1.9375 Z-0.2362 I-0.1875 J0.
N395 X-1.5625 Z-0.2559 I0.1875 J0.
N400 X-1.9375 Z-0.2756 I-0.1875 J0.
N405 X-1.5625 Z-0.2953 I0.1875 J0.
N410 X-1.9375 Z-0.315 I-0.1875 J0.
N415 X-1.5625 Z-0.3346 I0.1875 J0.
N420 X-1.9375 Z-0.3543 I-0.1875 J0.
N425 X-1.7353 Y-1.6869 Z-0.3647 I0.1875 J0.
N430 X-1.5648 Y-1.4707 Z-0.375 I-0.0147 J0.1869
N435 X-1.9352 Y-1.5293 I-0.1852 J-0.0293
N440 X-1.5648 Y-1.4707 I0.1852 J0.0293
N445 X-1.5934 Y-1.4499 I-0.0247 J-0.0039
N450 G1 X-1.6058 Y-1.4518
N455 X-1.6096 Y-1.4525 Z-0.3747
N460 X-1.6134 Y-1.4531 Z-0.3738
N465 X-1.617 Y-1.4536 Z-0.3723
N470 X-1.6203 Y-1.4541 Z-0.3702
N475 X-1.6232 Y-1.4546 Z-0.3677
N480 X-1.6257 Y-1.455 Z-0.3647
N485 X-1.6278 Y-1.4553 Z-0.3613
N490 X-1.6292 Y-1.4556 Z-0.3577
N495 X-1.6301 Y-1.4557 Z-0.3539
N500 X-1.6304 Y-1.4558 Z-0.35
N505 G0 Z0.6
N515 M5
N520 G53 Z0.
More
04 Mar 2017 23:54 #89012 by tommylight
It is all good here, see attached.
The only thing (besides some weird tool changes and Z0.???? ), check the tool to be used and the radius you are trying to cut, tool has to be smaller diameter than the radius to be cut.
Attachments:
More
05 Mar 2017 01:14 #89014 by Jake
Thanks Tommy!

Its a 1/4 endmill, 9.5mm = .0.374 + 0.25 should put me right there. A guy on the Fusion forum said move my tolerance to 0.0001 and it made it happy, Ill go try it in a little bit.

The "Z0.???"
Are you talking about line N315? Yeah I could add some top clearance in, I left it since the 25/64" hole is already drilled so I can rapid right to the top of the piece.
More
05 Mar 2017 02:50 #89017 by Jake
I had my tool table screwed up. When I was setting my Z offsets on the tools I didnt have the correct axis selected it looks like. As the T2 and T5 offsets were in the Y. It runs on the SIM. We will see if it will run tommorrow. thanks again for the help.
More
26 Mar 2017 17:13 #90302 by turbo
I'm having the same problem, but on my lathe. When you say that changing the tolerance to .0001 fixed it do you mean the fusion post options screen? I did that and it didn't change anything.
More
26 Mar 2017 17:17 #90303 by turbo
It stops at n55

File Attachment:

File Name: 1012.ngc
File Size:2 KB
Attachments:
More
26 Mar 2017 17:22 #90304 by turbo
Can I override the error? I just want it to run the code that I feed it.
More
27 Mar 2017 10:43 #90345 by andypugh
On a lathe it might be a problem with radius/diameter mode or absolute/relative hole centres.

If you over-ride the error, what do you expect LinuxCNC to do? It can't work out from the input data what the arc radius is.

What is the exact error message, the starting-point of the arc and the G-code line that errors?
More
27 Mar 2017 14:27 - 27 Mar 2017 15:08 #90373 by Jake
I changed the tolerance in Fusion in the model not in the post processor. It was under preferences I believe, ill look tonight

Make sure your tool offsets are correct also. I have screwed up by having the wrong axis selected when touching off a tool which placed the offset in the wrong axis in the tool table.

Also if your cutter is too large for the radius it will give you that error also.
Last edit: 27 Mar 2017 15:08 by Jake.
More
27 Mar 2017 23:36 - 27 Mar 2017 23:41 #90405 by turbo
In the tool table am I correct doubling my tool tip radius and putting that in the diameter column? So for my OD profiling tool I have .08 in the diameter column since the tool tip radius is .04mm.

I think I got past this problem yesterday by reducing the tolerance and turning on smoothing in the profiling op. Once I got past that I realized that the g76 format from the tormach post was totally wrong anyway.
Last edit: 27 Mar 2017 23:41 by turbo.
Moderators: Skullworks
Time to create page: 0.211 seconds
Powered by Kunena Forum