Résolu : Linuxcnc 2.9 avec Debian 10 probleme True Type Tracer manquant

More
23 Jan 2023 18:58 - 01 Feb 2023 10:38 #262757 by benhurburg
Bonsoir,
Peu habitué à Linux j'ai une cnc "maison" qui tourne sur un vieux pc sur le port // .
J'ai  installé une nouvelle version ( 2.9 sur Debian10 prerempt RT ) en secours sur un PC en 64 bits.
Tout semble correct sauf que sur axis impossible d'avoir TTT.
Après recherche ce logiciel n'est pas installé.
J'ai tenté d'installer la version 4.1 mais il y a des erreurs dues à des dépendances manquantes.

Comment résoudre ce problème ?
Merci
Last edit: 01 Feb 2023 10:38 by benhurburg.

Please Log in or Create an account to join the conversation.

More
24 Jan 2023 17:31 #262828 by macsddau@linuxcnc
La page d'accueil du repo git de TrueType Tracer indique les dépendances à installer :
git, cmake, FreeType, boost-python
voir :  github.com/aewallin/truetype-tracer
sudo apt-get install git make FreeType boost-python

Start page of git repo says to have some dependencies installed :
git, cmake, FreeType, boost-python
see : github.com/aewallin/truetype-tracer
sudo apt-get install git make FreeType boost-python
 
The following user(s) said Thank You: benhurburg

Please Log in or Create an account to join the conversation.

More
24 Jan 2023 18:47 #262829 by benhurburg
Je testerai ça demain et je viendrai rendre compte ensuite.
Merci

Please Log in or Create an account to join the conversation.

More
25 Jan 2023 13:53 #262882 by benhurburg
Bonjour,
rien ne va:

 sudo apt-get install git make FreeType boost-python
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Aucune version du paquet make n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « make » n'a pas de version susceptible d'être installée
E: Impossible de trouver le paquet FreeType
E: Impossible de trouver le paquet boost-python
root@debian10cnc:~#

Encore besoin d'aide ....
 

Please Log in or Create an account to join the conversation.

More
27 Jan 2023 17:00 #263015 by benhurburg
Linuxcnc 2.9 n'a pas l'air de passionner les foules ...

Please Log in or Create an account to join the conversation.

More
28 Jan 2023 08:01 #263061 by macsddau@linuxcnc
Désolé je ne peux pas plus t’aider.

Sorry I can’t help you more.

Please Log in or Create an account to join the conversation.

More
28 Jan 2023 10:08 #263065 by rodw
Because 2.9 requires Python3, I never had any luck installing it on Debian 10. Its probably looking for packages that dont exist. Upgrading to Bullseye or Bookworm should work. 

I prefer Bookworm so you can install linuxcnc and PREEMPT_RT with:
sudo apt install linuxcnc-uspace
sudo apt install linuxcnc-uspace-dev
The following user(s) said Thank You: benhurburg

Please Log in or Create an account to join the conversation.

More
28 Jan 2023 19:50 #263109 by benhurburg
I will upgrade tomorow , I hope , on the cloned disk.
I will use this how to :
phoenixnap.com/kb/upgrade-debian-10-to-11

Please Log in or Create an account to join the conversation.

More
28 Jan 2023 22:55 #263131 by rodw
The danger in upgrading is you will have python 2.7 and python3 on the PC so there are opportunities for confusion.

Please Log in or Create an account to join the conversation.

More
29 Jan 2023 08:09 #263157 by benhurburg
Is it possible to delete python 2.7 before upgrading or after?

Please Log in or Create an account to join the conversation.

Moderators: darty367
Time to create page: 0.418 seconds
Powered by Kunena Forum