Spindle index-enable for threading repeat passes.

More
25 Oct 2011 15:04 #14234 by andypugh
NICKKINSMAN wrote:

The pin state was showing 'FALSE at start. I was able to unlink the encoder, although the thread turned out to be unlinkp hm2_5i20.0.encoder.04.index-enable. Not sure if the hm2 is significant or not, but thats what it would accept. It also shows <=> motion.spindle-index-enable linked up as well (left that linked to begin with).

delsig spindle-index-enable would have the same effect, and unlink both sides at the same time.

I then ran the setp hm2......... true and the command box showed it had been set to true. However, the 'value' still remained at 'FALSE', even when rotating the spindle.

It should go "TRUE" until the encoder index mark is seen. If it is showing "FALSE" then this means that it has instantly reset. This could be due to the index being permanently high (which you have shown in HALCOPE isn't true) or possibly noise in the signal that is visible to the Mesa card, but not to Halscope.
I wonder if this whole thing is due to VFD noise? How fast can you turn the spindle by hand?

Can you repeat this exact experiment with encoder.04.index-invert set (you can make that change in the hal config window, I think)

Also tried unlinking the motion.spindle-index-enable as well, and setting to 'true' again, but still no change (despite saying it had changed)

You won't ever be able to set motion.spindle-index-enable I don't think.
[/quote]

Please Log in or Create an account to join the conversation.

More
31 Oct 2011 17:38 #14471 by NICKKINSMAN
I will check this out again with the -invert when I get a chance, have been too swamped to mess with the threading.

I do not hav a VFD - I actually have a DC spindle control, but the servo encoders route through the same conduit and they don't appear to be having any problems, although they are turning much slower, of course. I can turn the spindle up to about 100 RPM or so by hand. I was doing that whnn testing with the halscope and I also started and ran it while using the halscope. I only did the manual link/unlink commands by hand, so no power to the spindle to mess it up, and still no change from FALSE to TRUE.

I have a spare encoder, I may try hooking that up directly to the mesa board and seeing if it works. Just a pain to do becuase i don't have the connector, I will have to solder on the test leads or something.

Thanks, I hope to get back to checking it out again soon.

Nick

Please Log in or Create an account to join the conversation.

Time to create page: 0.073 seconds
Powered by Kunena Forum