stepper runs better in Stepconf than in Axis

More
05 Dec 2012 05:22 #27214 by peter76
Hello, new user here.

I'm building a plasma cnc cutter and have finished most of the mechanical stuff. It is an xyy configuration ( z will be manually for the moment ) using Leadshine M 542 stepper drivers and appropriate motors.
Now the weird thing is that if I jog the x-axis in the Stepconf wizard it runs very smooth and up to 40 mm/s, but when I jog it in Axis it quickly stalls at that speed.
Max speed in Axis is about 27 mm/s. But it sounds a bit "harsh".
If I set this speed int Stepconf and jog the axis it runs much smoother; no harsh sounds.
Both Stepconf and the drivers are set to 4x microstepping and when jogging in Axis the displayed distance equals the moved distance.
Hope anybody knows what's going on here....

Regards, Peter
Attachments:

Please Log in or Create an account to join the conversation.

More
05 Dec 2012 06:00 #27218 by skunkworks
Have you run a latency test? If so - did you run it while taxing the system? glxgears, browser, file transfers all at once?

Also - you could while running the stepconf jog utility - have glxgears, browser running a youtube vid, file tranfers - running in the back ground and see if it 'sounds' the same as when axis is running?

(I am wondering if the jitter goes up when you start loading the system)

sam

Please Log in or Create an account to join the conversation.

More
05 Dec 2012 06:09 #27219 by peter76
Yes, did a latency test and loaded the system, but I was a bit sneaky there, latency wasn't to bad, unless I started Draftsigt....
But Axis could do the same as Draftsight :-(
I'll try Stepconf again tomorrow while loading the system and report back.

Thanks,

Peter

Please Log in or Create an account to join the conversation.

More
05 Dec 2012 06:50 #27221 by BigJohnT
Try one of the GUI's that doesn't use OpenGL like TK. Might be an OpenGL issue...

John

Please Log in or Create an account to join the conversation.

More
05 Dec 2012 07:05 #27222 by cncbasher
try dropping the max acceleration to 70 in your ini file

Please Log in or Create an account to join the conversation.

More
06 Dec 2012 04:30 #27260 by peter76
Ok, first did a new latency test today; strangely enough max jitter wouldn't go past 26000 or so; it used to shoot up to 80000 when starting Draftsight... Problem persisted though, so I started "abusing" the computer while testing the x-axis in Stepconf. This was it! even doing something simple like starting the terminal would make the stepper motor "noisy" or change pitch.
Then by sheer luck ( IMHO ) I tried loading the computer more by doing the cpu hog as mentioned somewhere in the wiki:
while true; do echo "nothing" > /dev/null; done

This also changed the pitch of the stepper, but it was much more constant and smooth. Tried in Axis and works perfect. Upped the speed to 55 mm/s and the acceleration to 200 and it works great!
When I stop the cpu hog the steppers immediately stall with these settings.
Very happy it is working now, but would appreciate it very much if someone could explain, 1. Why there apparently is still more jitter than the latency test sees and 2. why maxing out the cpu makes the software stepper ( I guess ) work better

Thanks in advance.

Regards, Peter

Please Log in or Create an account to join the conversation.

More
06 Dec 2012 05:01 #27262 by peter76
PS,

Just reading this wiki page

wiki.linuxcnc.org/cgi-bin/wiki.pl?RealTime

At the bottom is the "cpu-hog" part, but this does seem to have to do with multicore or Hyperthreaded systems; mine is a Pentium 4, but HT is turned off.

Please Log in or Create an account to join the conversation.

More
06 Dec 2012 08:26 #27271 by BigJohnT

Please Log in or Create an account to join the conversation.

More
06 Dec 2012 15:20 #27291 by peter76

Did you isolate one core with isolcpus?

wiki.linuxcnc.org/cgi-bin/wiki.pl?The_Is..._Parameter_And_GRUB2

John


No, but the pentium 4 is a single core isn't it? Though I never checked if after disabling Hyperthreading in the bios only one cpu showed in /proc/cpuinfo.
I'll check that later.

regards, Peter

Please Log in or Create an account to join the conversation.

More
06 Dec 2012 18:49 #27297 by ArcEye
Hi

There were some dual core P4 processors very late in production I think, but yours is won't be one if it shows up as a single processor with /proc/cpuinfo.

Some Intel Pentium 4 processors had hyperthreading technology which allows the operating system to see one core as two and you got two cpu graphs in task manager.
One could mistake the Pentium 4 HT CPU for a dual core processor by looking at the task manager but it is in fact not a dual core processor.

See also my FAQ www.linuxcnc.org/index.php/english/forum...me-latency-solutions

isolcpus therefore will do no good, just disabling hyperthreading and all power management is all you can do.

Why the cpu hog works, is not the same as with a dual core processor.

I would suspect that because it consumes a lot of time but uses very little code, it absorbs all the slack for lower priority processes whilst leaving all the code that Linuxcnc needs in cache and quickly available to high priority processes.

Quickly looking at your .ini file, what you really need to do is tune your system.
You have a default value of 100,000 for the base thread which does no fit with your reported max jitter of 26,000 and does not mesh well with your very high acceleration values and quite high velocity values.

Your driver timings for a M542 as per your stepconf file are all wrong (too high) save one , see
wiki.linuxcnc.org/cgi-bin/wiki.pl?Stepper_Drive_Timing

Then read
wiki.linuxcnc.org/cgi-bin/wiki.pl?Tweaki...ftwareStepGeneration

regards

Please Log in or Create an account to join the conversation.

Time to create page: 0.077 seconds
Powered by Kunena Forum