Z homed DRO red !

More
10 Mar 2017 09:42 - 10 Mar 2017 09:44 #89322 by dinkata
dinkata created the topic: Z homed DRO red !
I upgraded Linuxcnc 2.7 to Linuxcnc 2.8
I want a new gmoccapy :) .
After homing Z DRO remains in red !!??
I'm wrong or there is a bug ?
Last Edit: 10 Mar 2017 09:44 by dinkata.
More
11 Mar 2017 23:01 #89440 by newbynobi
newbynobi replied the topic: Z homed DRO red !
I will check ASAP, but that screen is modified, what are the result with original lathe screen?

Norbert
More
12 Mar 2017 02:31 - 12 Mar 2017 02:33 #89454 by dinkata
dinkata replied the topic: Z homed DRO red !

what are the result with original lathe screen?

Yes original .
If we use sim gmoccapy then no problem .
If we use step wizard or pncconf then this problem .
Last Edit: 12 Mar 2017 02:33 by dinkata.
More
12 Mar 2017 13:27 #89464 by newbynobi
newbynobi replied the topic: Z homed DRO red !
I just checked the following:

I made a config with stepconf, using 2.7, I started that config and homed the machine: No Problem
I changed over to master and started the same config "it is then converted to 2.8 style": No problem.

Post your config!

Norbert
More
13 Mar 2017 04:25 - 13 Mar 2017 04:33 #89501 by dinkata
dinkata replied the topic: Z homed DRO red !
Hello Norbert , thanks for the reply !
I like very much gmoccapy . We work on two lathe and a milling machine.
I want to use function "tool wear" in tool table . Therefore upgraded 2.7.8 => 2.8 .
Please see,done properly ?


Then I made configuration (applied)


File Attachment:

File Name: LatheTest.tar.gz
File Size:5 KB


P.S. After homing pin joint.0.homed = 1 , pin joint.1.homed = 0 !!??
Attachments:
Last Edit: 13 Mar 2017 04:33 by dinkata.
More
13 Mar 2017 09:37 #89506 by rodw
rodw replied the topic: Z homed DRO red !
Have a look at the [KINS] section of your .ini file and if you have this in your KINEMATICS = line try removing it.
KINSTYPE=BOTH

There have been a few changes in Master to integrate the joint axis code that had some impact on Gmocappy which were only fixed recently. When I was trying to solve a now fixed bug, I had a red axis a couple of times....

Removing the kinstype=both means that individual joint mode is disabled but that should not be an issue on a lathe.
The following user(s) said Thank You: dinkata
More
13 Mar 2017 10:14 #89508 by dinkata
dinkata replied the topic: Z homed DRO red !
ini :

[KINS]
JOINTS = 2
KINEMATICS = trivkins coordinates=XZ

More
13 Mar 2017 21:52 #89554 by newbynobi
newbynobi replied the topic: Z homed DRO red !
I am on my fone, but without looking in your config i do know, you are using a corrupt config.

A lathe is a identity kinematics, so you need 3 joints, X being joint 0 and Z being joint 2.
Joint 1 is unused and does not need to be in your ini file.

Change joints to 3 and rename your joint 1 to joint 2.
After that the dro problem should be gone.

Norbert
More
14 Mar 2017 04:51 - 14 Mar 2017 04:58 #89569 by dinkata
dinkata replied the topic: Z homed DRO red !
Hello Norbert , thanks for the reply !

Change joints to 3 and rename your joint 1 to joint 2.

I did this,but there is another problem .This is config real machine :
ini:
Warning: Spoiler! [ Click to expand ]

hal
Warning: Spoiler! [ Click to expand ]

In this configuration, when pressed the button -X or +X normal move
but when pressed the button -Z or +Z joint.2.vel-cmd =0 joint.1.vel-cmd = 3
[ jog speed = 180mm/min ( and another problem show sometimes inch/min ) ]
joint.1 error !!!!!!??????
Attachments:
Last Edit: 14 Mar 2017 04:58 by dinkata.
More
14 Mar 2017 17:24 #89614 by andypugh
andypugh replied the topic: Z homed DRO red !

dinkata wrote: ini :

[KINS]
JOINTS = 2
KINEMATICS = trivkins coordinates=XZ


I have my lathe set up as 2 joints and use the 2.8 version of LinuxCNC.

I use the Touchy GUI and have noticed that I don't get a "homed" indicator in the GUI for the Z axis.
This looks like exactly the same problem. (Except it isn't really a problem for me, and I have ignored it).

I will try some experiments tonight to see if I can see the problem.
The following user(s) said Thank You: dinkata
Moderators: newbynobi
Time to create page: 0.259 seconds
Powered by Kunena Forum