Problem Updating from 2.6 to 2.9

More
3 years 4 months ago #272897 by kt600v
Hello guys, I have a lathe with linuxcnc 2.6 wich I need to upgrade to 2.9
Updating  from 2.6 to 2.7 worked fine by following the instructions from the manual.
Updating 2.7 to 2.8 :  I used  the script which converts configuration files automatically , when launching for the first time suddendly I get an error log (attached please zoom the image).At this point I coudn`t figure out the cause.I wonder if you guys would be willing to help me with this issue.

Please Log in to join the conversation.

More
3 years 4 months ago #272899 by tommylight
Edit the custom_postgui.hal with a text editor (not office stuff), omit or delete the line 7 that contains
motion.spindle-brake
ONLY if you are not actually using a spindle brake.

Please Log in to join the conversation.

More
3 years 4 months ago #273171 by kt600v
Linuxcnc 2.8.4 works very well so far, I'm going to update to 2.9, I'll use the method wich consist of downloading the latest deb file (from buildbot) and installing it with dpkg. My question is ig this is a good way to go, or could anyone suggest me another  one. thank you

Please Log in to join the conversation.

More
3 years 4 months ago #273179 by tommylight
Use gdebi to install debs, it is a GUI package manager and is a bit safer than dpkg
sudo apt install gdebi
after installing this, just double clicking on a deb file from the file explorer with open it, no need for terminal.

Please Log in to join the conversation.

More
3 years 4 months ago #273365 by kt600v
I´ve a question, is it possible to roll back to previous version by installing older deb the same way Updates are installed?

Please Log in to join the conversation.

More
3 years 4 months ago #273510 by tommylight
To some extent, yes.
To be safe, save the new or working debs, then
sudo apt purge linuxcnc-uspace
then try installing the deb you want.

Please Log in to join the conversation.

More
3 years 4 months ago #273558 by kt600v
When trying to install lastest deb (2.9) I got some errors and it couldn't be updated (2.8.4 ==> 2.9). I couldn't install gdebi either so  I used dpkg.

I made a new clean install but errors persist.

I couldn't figure out how to solve this. Need help


 

Please Log in to join the conversation.

More
3 years 4 months ago #273559 by tommylight
sudo apt update
sudo apt install gdebi
then
uname -a
lsb_release -a

Please Log in to join the conversation.

More
3 years 4 months ago #273725 by kt600v

sudo apt update
sudo apt install gdebi
then
uname -a
lsb_release -a


this is what i get 

Attachment not found

 

Attachment not found

Please Log in to join the conversation.

More
3 years 4 months ago #273726 by tommylight
Something wrong with your repository file, what is the error from
sudo apt update
?

Please Log in to join the conversation.

Time to create page: 0.072 seconds
Powered by Kunena Forum