Troubles with Ethercat and Beckhoff EK1100

More
25 Feb 2017 15:00 - 25 Feb 2017 17:55 #88616 by hardware_crash
hardware_crash created the topic: Troubles with Ethercat and Beckhoff EK1100
Hey guys,
As I had a Beckhoff EK1100 laying in my shelf for about two years , I tried to connect it to linuxcnc for some testing .
I Installed the newest linuxcnc version to a small desktop pc with an Intel D525mw Mainboard which I use for all my testing setups.
I think I have read all the tutorials and instructions I could find for Ethercat with linuxcnc but I am not able to make it run.
As far as I understood there has to be the etherlab master installed on the machine and a glue to make the pins available in a Hal file .
So I installed everything with this instruction : http://wiki.linuxcnc.org/cgi-bin/wiki.pl?EtherCatDriver

I am able to list the connected slaves with : $ ethercat slaves
But thats it .. I can't find a way to connect the ethercat part to a Hal file and linuxcnc.
There are so many different descriptions for that case and each shows another way to make the glue between ethercat and Hal .
But none of them worked for me ....

It also seems that the source under https://github.com/sittner/linuxcnc/tree/add-hal-ethercat isn't available anymore :unsure:

Any information on how to do that would be great :)
Last Edit: 25 Feb 2017 17:55 by hardware_crash.
More
28 Feb 2017 13:50 #88726 by andypugh
andypugh replied the topic: Troubles with Ethercat and Beckhoff EK1100

hardware_crash wrote: It also seems that the source under [url=https://github.com/sittner/linuxcnc/tree/add-hal-


Try
github.com/sittner/linuxcnc-ethercat
Time to create page: 0.090 seconds
Powered by Kunena Forum