linuxcnc ethercat lcec issue

More
11 Mar 2017 05:42 #89404 by superbird688
superbird688 created the topic: linuxcnc ethercat lcec issue
Hi experts!

I am just touching this clever cnc software but in the stage of initialization with ethercat
Here is my simple hal test run:

loadusr -W lcec_conf ethercat_config_n.xml
loadrt lcec
loadrt trivkins
loadrt motmod base_period_nsec=0 servo_period_nsec=1000000 num_joints=1

addf lcec.read-all servo-thread
addf lcec.write-all servo-thread

start

And as I run linuxcnc selecting one I generated, it shows the following message

could not insert module /usr/realtime-3.4-9-rtai-686-pae/modules/linuxcnc/lcec.ko: Invalid parameters

I use intel pro1000 , under linuxcnc 2.7.8 , I as well tried 8139too but still having this trouble

By the way my servo ASDA-A2 Delta Electronics

Please help.....Thanks in advance!
Attachments:
More
13 Mar 2017 12:58 #89511 by andypugh
andypugh replied the topic: linuxcnc ethercat lcec issue
Is there any more information in dmesg?

Looking at the source most of the faults print an explanatory message prior to giving up.

You could try an even simpler test file (don't load trivkins, and use "loadrt threads" instead of motomod, and then addf ... thread1 ) However that probably won't help.

What Linux kernel are you using (uname -a)
More
13 Mar 2017 14:59 #89526 by db1981
db1981 replied the topic: linuxcnc ethercat lcec issue
first check if your ethercat master ist working.

simply type in terminal : ethercat slaves

if your slaves are shown there, the problem is in LCNC or your config xml.
More
14 Mar 2017 14:15 #89587 by Wirewrap
Wirewrap replied the topic: linuxcnc ethercat lcec issue
Is base_period=0 an accepted value? If you want no base period, just leave it out.
More
15 Mar 2017 15:04 - 15 Mar 2017 15:10 #89670 by superbird688
superbird688 replied the topic: linuxcnc ethercat lcec issue
Thanks for all your help.

I went back to my problem and it was something wrong with my ethercat-config xml file.

I modified 5 servo slaves with type="DeAsda" since mine are Delta electronics motors, and luckily it has
deasda.h and c in the src already.

But if the motors are something else than asda, I might have trouble since i can't be sure if my generic type of xml
is good to go....
Last Edit: 15 Mar 2017 15:10 by superbird688.
More
01 Aug 2017 10:12 #96819 by dan.k
dan.k replied the topic: linuxcnc ethercat lcec issue
Hi all,

I saw that you are using ASDA-A2-E with Linux CNC. Please, can you describe me the procedure of loading configuration for this servo drive? Do I need XML file or can I load deasda.c somehow?

I will appreciate your help

Thank you in advance
More
05 Aug 2017 20:34 #97046 by superbird688
superbird688 replied the topic: linuxcnc ethercat lcec issue
Hi Dan.K
Please search swm-f45a which is a good example to use asdaa2 profile.

Cheers
More
10 Aug 2017 05:54 #97275 by dan.k
dan.k replied the topic: linuxcnc ethercat lcec issue
Hi superbird,

thank you for information, I looked in the files and it helped me. But I have a question about xml file. Did you use it with DeASDA name only or with generic and defined PDOs by yourself? I have a problem because in dmesg I got a message that "Slave does not provide information about sync managers", even if I use generic xml with sync managers defined. Did you meet with this? Please, can you share with us your successful configuration for ASDA-A2-E?

Thank you very much
More
18 Aug 2017 07:39 #97691 by dan.k
dan.k replied the topic: linuxcnc ethercat lcec issue
Hi all,

I'm testing on Delta ASDA-A2-E 200W and if I try to setup with swm-fm45a example from Sascha Ittner, it shows me only information in dmesg that slave does not provide information about sync managers. I think it's problem of defining FMMU because in original XML they are defined and they are not in E2PROM. Is it possible to add somehow FMMU definition of FMMU to generic XML file? It does not work also with DeASDA.

Thanks

Daniel
Time to create page: 0.098 seconds
Powered by Kunena Forum