Bad routing path

More
19 Sep 2016 12:25 #80601 by yo9hnf
Hi,

In the past i had (i think...) LinuxCNC 2.4...i'm not shure. Now i had change my PC with a newer one and installed ver. 2.7.0.
I see some path errors...

You can see the path...

In the 3rd photo it's a hole (larger that the first one (43.5 x 27.5 mm)) made with the old PC (old Emc2). In the last photo is the hole made with ver. 2.7.0.

Can you guys help me with this ?

Thank you !

Dan
Attachments:
More
19 Sep 2016 14:06 #80608 by seb_kuzminsky
What is your G64 P set to?
More
19 Sep 2016 14:18 #80614 by tommylight
And acceleration also, what are the values.
I remember having the same issue with 2.7, so as SEB said, use the G64 Pxx .
More
19 Sep 2016 14:20 - 19 Sep 2016 14:27 #80615 by yo9hnf
I don't have any G64 line in my code (VCarve).
I use an 3.175mm end-mill.


Max. Acceleration : 60m/s^2
Max. Velocity : 20mm/s^2

How should i use the G64 ?
Attachments:
Last Edit: 19 Sep 2016 14:27 by yo9hnf.
More
19 Sep 2016 15:04 - 19 Sep 2016 15:06 #80617 by tommylight
Add a G64 P0.1 Q0.1
If your tolerance has to be within 0.1mm, or as you might need.
You can also use it without the Q .
Attached you have your file with that line added.

Please note that if you stop the program execution at any point, you will have to add that G64 line to MDI before using "run from here".
Attachments:
Last Edit: 19 Sep 2016 15:06 by tommylight. Reason: Added more info
More
19 Sep 2016 15:27 #80619 by yo9hnf
NIce !!! Thank you guys !
It's working :) !!!

I've inserted G64 P0.00125 (finded on web) like this :

%
G21 G40 G49 M6 T1
G17
M7

G64 P0.00125

G0Z20.000
G0X0.000Y0.000S12000M3
G0X44.581Y-19.782Z6.000
G1Z-1.433F100.0

It's working great. Tomorow i'll trie with G64 P0.1 Q0.1



BUT...where was the problem ? I've never gad G64 inserted but LinuxCNC worked very well. It's a ver 2.7.0 issue ?
More
19 Sep 2016 17:51 - 20 Sep 2016 15:27 #80624 by Todd Zuercher
With the introduction of version 2.7 there was a huge change to how the trajectory planner works in Linuxcnc. in previous versions Linuxcnc would never go faster than the speed it could achieve and still come to a complete stop by the end of the next line of code (one line look ahead) and G64 Px path-blending was parabolic. This worked fine unless your code contained curves made up of tiny line segments, such as the code produced by most cam programs for 3-d carving. (This could slow a machine with low acceleration rates to a crawl.) In 2.7 the one line look-a-head limitation was removed, and the planner reprogrammed to read ahead in the g-code to calculate the feed rates necessary to maintain the G64 Px tolerances through multiple lines. This can allow much higher feed rates and smoother motion through small segmented code. In order to make the programming of the new trajectory planner more manageable, the G64 path-blending was changed from parabolic to circular. The basic behavior in G61 exact stop mode should have been unchanged. However if you were using G64 with no P tolerance, the difference could have been quite large, because of increased speed potential between the new and old versions. (I can not tell you what G64/G61 setting would have been the default for your old configuration.)
Last Edit: 20 Sep 2016 15:27 by Todd Zuercher.
More
20 Sep 2016 15:02 #80675 by yo9hnf
Hey guys !

I tried with yesterday G64 P0.00125 and today G64 P0.1 Q0.1 but i didn't see any difference .

Thank you soo much for helping me !!!
More
17 Mar 2017 14:46 #89826 by yo9hnf
Hey Guys,

I have (i think) the same problem again...


Before this problem i used tommylight method and my programs was like this :

%
G21 G40 G49 M6 T1
G17
G64 P0.1 Q0.1
M7
G0Z20.000
G0X0.000Y0.000S12000M3
G0X52.765Y29.061Z6.000
G1Z-2.300F100.0
etc....

Few days ago i've seen that i can no longer route circles; the machine will draw any shape exapt circle (not oval...something...a very strange shape).
Today i saw that i have another routing problem, see the picture.



I changed the G-code generator from Vcarve 6 to Aspire 8.5 and i did two tests...i saved the NGC file with G64 extension and again with G61 extension...but the problem is still there. The shave are not equal and unregulated (like the end-mill was not finishing it path).

Now my code looks like this (for G61 and without my edited line G64 P0.1 Q0.1).
%
G21 G40 G49 G61 M6 T1
G17
M7
G0Z20.320
G0X0.000Y0.000S12000M3
G0X212.829Y112.330Z5.080
G1Z-2.000F100.0
G3X213.341Y111.818I0.512J0.000F600.0

The test was made with laminated wood (like the one used in furniture), with a fi 3.175mm single flute mill with the following specs:
Pass Depth - 2mm ;
Stepover - 1.27mm - 40% ;
Feed Rate - 600 mm/min ;
Plunge Rate - 100 mm/min ;

I use LinuxCNC Rev. 2.7.0 .

Any ideas ? :)

Thank you !

Regards,
DAN

PS : Could this be a machine problem ? If yes, how can i determine if X or Y axis are faulty ?
More
17 Mar 2017 15:33 #89828 by tommylight
That is most probably something loose on the machine or spindle.
If the error is in the left-right direction that means X axis has something loose. If it is on the up-down, Y axis.
As for Z and spindle, try to move it by hand and see if something moves or gets out of whack.
Time to create page: 0.204 seconds
Powered by Kunena Forum