Joint following error and congifuration for delta robot

More
09 Mar 2017 15:28 #89258 by andypugh
andypugh replied the topic: Joint following error and congifuration for delta robot
Is this with your config, or the original config?
I would expect this if the kinematics config doesn't match the Vismach model exactly.
More
15 Mar 2017 14:50 - 15 Mar 2017 14:59 #89667 by k-1
k-1 replied the topic: Joint following error and congifuration for delta robot
First of all sorry for my bad English ... I hope to be clear, however.

@andypugh ... your suggest is obviusly the best (move to 2.8 and use definited kins) but personally I use the kins of "Radek" from 2012 without any particular problem since 2.6 not ja.... obviusly JA and actual master is better for teleop and other particularity, but the kinematics itself should work without problems and without axes tracking errors .... having said that like you said is very recommendable to use 2.8.

@Radeck
some highlight:
1-in rotary delta the axis x,y,z is not the same of joint0, joint1, joint2 ... so if Radek use the radek kins and not 2.8 master or old JA in manual joint0, joint1, joint2 move one motor at time, in teleop or auto move axis x,y,z ... not the same of motor 0 motor 1 and motor 2.
2-if radek use JA or new 2.8 master you can choose between manual sengle axis and manual teleop (so 3 motor move at time).
3-for simplify the mecanicals joint0 motor = joint1 motor = joint2 motor (the same for reducer and encoder and drive if you use)
4- 3 identical servomotor 3 identical ferror, max acc, maxvel, and other .... if you use chiper drive P/I/D/ff/ff0 may be different, but normally is equal.
5- if some of INI parameter is different ... maybe only your writing error, but maybe different reducer or encoder, or drive if you have test for first every single axis ....
6-you have some weight or friction connected to one of your arms?
7-.....
#+ Third axis
[AXIS_2]
TYPE = ANGULAR
HOME = 0.000
MAX_VELOCITY = 80.0
MAX_ACCELERATION = 100.0
STEPGEN_MAXACCEL = 120.0
INPUT_SCALE =                   4000
OUTPUT_SCALE = 2.22
#OUTPUT_SCALE = 320.0
#COMP_FILE_TYPE = 0
#COMP_FILE = axis0.comp
FERROR = 20.0
MIN_FERROR = 5
HOME_OFFSET = 0.000
MIN_LIMIT = -360.0   /** put to -9999999.99 **/
MAX_LIMIT = 360.0   /** put to 9999999.99 **/
#HOME_OFFSET = 0.0
HOME_SEQUENCE =                 0
and suppress deadband in to hal file ....

8- your hal file??? is the same?

With these type of kins the Z is at anytime in minus area ....

The my firs delta was build with stepper motor ... so I had several tracking errors or geometrical errors due to the kinetic energies at play in this kind of machine. But I my max ferror was 4.5 .... I used only 100 or 200 step rev, because of the torque necessary to the movement of this type of machines.



I hope these help
Giorgio
Last Edit: 15 Mar 2017 14:59 by k-1.
Time to create page: 0.090 seconds
Powered by Kunena Forum