Rapid movement occurs below surface of material

17 Mar 2017 23:20 #89839 by rbarry1068
I am using a home made Solsylva machine (Gantry type mill/router) with the attached .ini file. The machine homes fine, and seems to move properly under manual control, but when I try to execute a gcode file, the rapid movement causes the router to lower into the workpiece instead of lift up from it. I must have a sign inverted somewhere, but I can't see it. Please help!!! Thanks in advance.
18 Mar 2017 01:23 #89840 by tommylight
Ini looks ok, attach other files, namely hal and the ngc that does what you describe. Did you check the tool table and tool offsets?
Generaly, when using Z axis with home, you need to home then lower Z to the workpiece and touch off.
Or you need to have tool offsets set in tool table and know the thicknes of the workpiece and touch of with that value.
Please do double check this, as i never use offsets and touch off, this info is from reading this forum.
18 Mar 2017 02:04 #89841 by rbarry1068
Here is my .hal file and a sample g-code file. I looked at several different g-code files in Axis, and they all show the rapid movement into the workpiece. While you are looking at .hal, I would like to setup so that if a limit switch is ever hit, it stops the machine. Right now, that doesn't seem to happen.

Thanks for your help.
18 Mar 2017 02:06 #89842 by rbarry1068
Didn't seem to get the g-code file attached. Here it is.
18 Mar 2017 02:10 #89843 by rbarry1068
OK, this time it might work. The file uploader is picky about file extensions.
18 Mar 2017 02:41 #89844 by Todd Zuercher
What does the g-code file look like? Perhaps the problem lies there.
18 Mar 2017 03:45 #89846 by rbarry1068
So, after homing the machine, I bring the router to the top of the workpiece (I'm doing an engraving) and touch-off, setting Z=0.0. All my g-code files are generated with 0.05" cutting depth and 0.1" rapid height. When I execute the g-code file, the router rises and Axis shows it tracing the engraving. When it hits a rapid move, it lowers into the workpiece. Obviously the Z motion is inverted somewhere, but where??
18 Mar 2017 13:28 #89857 by rbarry1068
Problem solved.

I figured out how to fix my problem. I edited the .hal file and added the following statement:

setp parport.0.pin-08-out-invert 1

right above the existing statement:

net zdir => parport.0.pin-08-out

Everything is now working properly.
Time to create page: 0.131 seconds
Powered by Kunena Forum