hal: lpt spindle quad encoder with pid

More
28 Dec 2014 23:18 - 28 Dec 2014 23:20 #54336 by juergen-home
juergen-home created the topic: hal: lpt spindle quad encoder with pid
The basic was generated by stepconf wizard.
The rest was copied from other hal-files and self coded.

File Attachment:

File Name: Meine-Masc...2-28.hal
File Size:6 KB


File Attachment:

File Name: custom_pos...2-28.hal
File Size:1 KB


File Attachment:

File Name: custompanel.xml
File Size:2 KB
Attachments:
Last Edit: 28 Dec 2014 23:20 by juergen-home.
More
29 Dec 2014 17:47 - 29 Dec 2014 17:54 #54360 by juergen-home
juergen-home replied the topic: hal: lpt spindle quad encoder with pid
So here some improvement of this draft system.
I use it to test my closed loop spindel configuration.
The hal file and all other config is inside the attaches zip.




connected:
Attachments:
Last Edit: 29 Dec 2014 17:54 by juergen-home.
The following user(s) said Thank You: danimal300
More
08 Jun 2016 01:19 - 08 Jun 2016 14:16 #75664 by danimal300
danimal300 replied the topic: hal: lpt spindle quad encoder with pid
Thank you for posting this! I have been trying to incorporate this into my machine, and I was wondering if you could walk me through the operation of your PID algorithm.

I am having problems tuning the speed values and my displayed spindle values jump all over the place, even when I have I and D off. are there other I and D values that need to be turned off to be in true proportional mode? I am talking like 500 - 10,000 jumps when set to 200 RPM.

I know that it has been years since you posted this, but any help that you could provide would be greatly appreciated.

Edit: disregard the jumping around issue, I forgot that I changed the low pass filter value to 1 when I was testing. I have it settled back down pretty well now.
Last Edit: 08 Jun 2016 14:16 by danimal300.
Time to create page: 0.112 seconds
Powered by Kunena Forum