incremental jog feedrate problem

More
14 Jan 2017 02:04 #85719 by Ivan_The_Red
Ivan_The_Red created the topic: incremental jog feedrate problem
I building an arduino pendant to use wih gscreen and everything is almost finished and ive ran into a problem i cant figure out , heres the situation.

When i run a cnc program i can use the feedrate potentiometer through the arduino and it works perfectly to change the feedrate as the program runs...no problem
When i enter mdi mode and enter a simple linear move the potentiometer still functions as expected.
When i use the keyboard to manuall jog an axis the potentiometer still functions perfectly.....now the oddity.

When i select an incremental jog and jog the axis the potentiometer doesnt work to adjust the feedrate and i cannot figure out why.

Any help would be greatly appreciated
Thanks....Jeff
More
14 Jan 2017 08:23 #85730 by cmorley
cmorley replied the topic: incremental jog feedrate problem
I don't see anything obvious in gscreen's code. Can you post your modifications?

Chris M
More
14 Jan 2017 22:59 #85787 by Ivan_The_Red
Ivan_The_Red replied the topic: incremental jog feedrate problem
Hey Chris , thanks for helping me tgrough all of these issues. I loaded up Gmocappy and used the sliders on that interface and it exibits the same behavior as mine does when using my arduino , could it be that linuxcnc is unable to dynamically adjust incremental feed commands?

Jeff
More
15 Jan 2017 01:30 #85801 by cmorley
cmorley replied the topic: incremental jog feedrate problem
According to the python interface to linuxcnc incremental speed can be set.:
from www.linuxcnc.org/docs/2.7/html/config/py..._linuxcnc_command_tt

c.jog(linuxcnc.JOG_STOP, axis)
c.jog(linuxcnc.JOG_CONTINUOUS, axis, speed)
c.jog(linuxcnc.JOG_INCREMENT, axis, speed, increment)

I am not sure how you are setting jog velocity or what other customizations you have done, so I can't help further until i do.

Chris M
More
15 Jan 2017 01:31 #85803 by cmorley
cmorley replied the topic: incremental jog feedrate problem
Gmoccapy was originally a skin of Gscreen so I am not surprised if there are common idiosyncrasies.

Chris M
More
15 Jan 2017 13:10 #85815 by newbynobi
newbynobi replied the topic: incremental jog feedrate problem
I just checked that on gmoccapy 2.2.3 , sim/gmoccapy/gmoccapy.ini

- out of estop
- switch on the machine
- home all
- jog with the jog buttons, all OK
- select 1.2345 in Jog increment
- lower the jog vel slider (just push turtle mode)
- push any axis button once

If you look at the velocity label, you will see, that my GUI is handling that correct!!!!
I also checked the code from gscreen, it is very similar and I am pretty sure it should behave correct as gmoccapy does.

Please check you config!

Norbert
More
15 Jan 2017 14:42 #85818 by Ivan_The_Red
Ivan_The_Red replied the topic: incremental jog feedrate problem
Thats whats happening with mine as well except if you try to adjust the feedrate during the move mine wont change the feedrate , it remains at the feedrate that it started with. Can you change the feedrate while yours is moving ?
More
15 Jan 2017 17:01 #85826 by newbynobi
newbynobi replied the topic: incremental jog feedrate problem
Hallo Ivan,

no, that is not possible, once the move has begone, you are not able to change the velocity till the move ends.
The commands has been send, so you will not be able to change its parameters.

Norbert
More
15 Jan 2017 21:58 #85862 by Ivan_The_Red
Ivan_The_Red replied the topic: incremental jog feedrate problem
Hi Norbert ,

Thanks for taking the time to look into that for me i really do appreciate that. I was hoping that was the case because i had no idea how to make that work....i tried everything i could.

Have a great day

Jeff
Moderators: mhaberler
Time to create page: 0.113 seconds
Powered by Kunena Forum