Where is the Glade HAL widgets installed with linuxcnc installed as a package

More
16 Feb 2017 21:23 #88075 by cncnoob1979
cncnoob1979 created the topic: Where is the Glade HAL widgets installed with linuxcnc installed as a package
Where is the Glade HAL widgets installed with linuxcnc, when linuxcnc is installed as a package, not as a RIP?

I have Linux Mint 18.1 with 4.9 Preempt kernel installed. I have compiled the glade 3.8.5 tarball and installed the program, however I can not get glade to insert the catalog for Linuxcnc Widgets. I have found what appears as a catalog in user/lib and also in the glade3 folder. [Cant remember exactly where now, I'm at work]. I exported the glade catalog search path to these folders but still I can not get it to import. I checked the in use search path by "echo $glade"... search path... something another :) Cant remember now!

Can someone point me in the area I need to research? I have tried the wiki and other posts on here that deal with a rip install.

I basically am trying to find out what is the catalog exactly, what file name am I looking for? Is there an error log or configuration file.. ect...

I do not get any errors when launching glade via the terminal. I have had this working before on a previous build and know about the complaints on missing icons etc. when its working. I need to edit my custom glade files I have in my setup.

What is required for Glade 3.8.5 to import these files? As stated above I have pointed the search path to every folder I could find dealing with linuxcnc widgets.
More
17 Feb 2017 05:38 #88100 by cmorley
cmorley replied the topic: Where is the Glade HAL widgets installed with linuxcnc installed as a package
I checked my ubuntu 10.04

in /usr/share/glade3/catalogs should be hal_python.xml
icons should be in usr/share/glade3/pixmaps

are these files present?

Chris M
The following user(s) said Thank You: cncnoob1979
More
17 Feb 2017 16:15 #88119 by cncnoob1979
cncnoob1979 replied the topic: Where is the Glade HAL widgets installed with linuxcnc installed as a package
Chris,

Thanks! When I get home today and on the mill I will check. I assume the .xml is the catalog container?

If I am not mistaken I have previously pointed to the catalog/pixmaps folders from a RIP I have been testing and glade still did not import the catalog. I assumed the path would be wrong [if looking in my rip] when the glade tires to parse the catalog.

Ill check my /usr/share/glade3/ folders and copy them over if not already present.
At this point I would - kill - just for a simple error from a failed catalog import!

Thanks again, Ill report back when I have an answer for you.
More
17 Feb 2017 23:16 - 17 Feb 2017 23:17 #88139 by BigJohnT
BigJohnT replied the topic: Where is the Glade HAL widgets installed with linuxcnc installed as a package
I have LinuxCNC installed on Linux Mint 17.3 and just installed Glade 3.8 from the synaptic package manager and the Hal widgets show up. Mint 18 might be a problem with libraries or something. I also checked the location that Chris has with Ubuntu 10.04 and Mint 17 has them in the same place. Two files gtk+.xml and hal_python.xml.

JT
Last Edit: 17 Feb 2017 23:17 by BigJohnT.
The following user(s) said Thank You: cncnoob1979
More
18 Feb 2017 00:05 - 18 Feb 2017 00:18 #88143 by cncnoob1979
cncnoob1979 replied the topic: Where is the Glade HAL widgets installed with linuxcnc installed as a package
Thanks Chris and JT!

I had glade 3.8.5 installed from source; I guess I did not use the prefex --user during the configure stage.

So to fix my issue I:

sudo make uninstall

while in my 3.8.5 extracted tarball [where I installed it] Glade 3.8.5 cleanly uninstalled.

Afterwards I went to launchpad.net/ubuntu/utopic/i386/glade-gtk2/3.8.5-0ubuntu1

Downloaded the libgladeui-1-11 (>= 3.7.2) depends and installed glade-gtk2_3.8.5-0ubuntu1_i386.deb, after issuing the glade-gtk2 command my HAL widgets showed up. :P

Talking about something to beat your head on! UGH! I'm up 100% now thanks for your guys help. Letting me know you have the same files and folder in the same location as me - kept me from thinking it was a path issue and I focused on a program/installation issue.
Last Edit: 18 Feb 2017 00:18 by cncnoob1979.
More
18 Feb 2017 00:39 #88145 by BigJohnT
BigJohnT replied the topic: Where is the Glade HAL widgets installed with linuxcnc installed as a package
I love it when a plan comes together.

JT
More
18 Feb 2017 02:48 #88154 by tommylight
tommylight replied the topic: Where is the Glade HAL widgets installed with linuxcnc installed as a package

BigJohnT wrote: I love it when a plan comes together.

JT


A team ?
Nice
More
02 Mar 2017 21:24 #88900 by CMB
CMB replied the topic: Where is the Glade HAL widgets installed with linuxcnc installed as a package
Hi cncnoob1979,

Did you have any trouble also getting the VCP Actions to show up in Glade?

When I tried Mint 18.1 -32bit I noticed there were missing items with LinucCNC 2.7.8 vs when I used the LinuxCNC 2.7.4 package I created about 6 months ago with Mint 17.3.

Could this be purely related to the version of linuxCNC?

I switched back to Mint 17.3 -64bit and got the results in the attached screenshot.

The left image is with Linuxcnc 2.7.4, and the right is 2.7.8.

Just trying to be sure I've got this setup correctly before I set off to learn about Glade!

Thanks,

cb
Attachments:
More
03 Mar 2017 01:51 #88909 by cmorley
cmorley replied the topic: Where is the Glade HAL widgets installed with linuxcnc installed as a package
something is not right there.
if you load glade from the terminal there may be an error message.
It will be hard to find as there are a lot of warnings about icons that are really just noise.

Chris M
More
03 Mar 2017 03:19 #88911 by cncnoob1979
cncnoob1979 replied the topic: Where is the Glade HAL widgets installed with linuxcnc installed as a package
Hey! I get all the HAL and VCP Actions as you have shown in the 2.7.4 image.

Something's going on there as Chris M. Pointed out. Have you tried looking at the files to see if they are the same?

Perhaps check for permission issues?

You Could try to launch in a terminal with sudo to verify permission issues.

Before you check for errors make sure to set your terminal buffer to no limit. So you can scroll up, there will be a lot of icons error which are normal.

The buffer setting is under the title bar of the terminal window.
The following user(s) said Thank You: CMB
Moderators: mhaberler
Time to create page: 0.078 seconds
Powered by Kunena Forum