(SOLVED) BUG REPORT: Gmocappy Homing buttons in joint mode in Master

More
18 Feb 2017 23:32 #88206 by rodw

cncnoob1979 wrote: Rodw,

Are you still running a rip? Have you tired to make clean, reconfigure and build it again without root?


Thanks, this was helpful and I solved my problem so I could test this code.

Norbert, this is working perfectly on my hardware. Thanks for taking this up. It nice the way the axes that can't be homed are greyed out.

Now I just have to learn a bit more about git so I can test some of dewey's development branches. Its funny , a friend who uses Mach3 was looking for the axis offset buttons in my version of Gmocappy just yesterday. He said Mach had a button beside the DRO's to set the current position to be Zero. It looks like this can be done now.
More
19 Feb 2017 02:35 #88226 by rodw
I wanted to test dewey's branch and I got a compile error.
Compiling realtime emc/motion/control.c
emc/motion/control.c: In function ‘update_coord_with_bound’:
emc/motion/control.c:2212:1: error: expected expression before ‘<<’ token
 <<<<<<< HEAD
 ^
emc/motion/control.c:2215:9: error: exponent has no digits
 >>>>>>> 3166ec6779e76783c14f0d58d47f62edcc8e155b
         ^
make: *** [objects/rtemc/motion/control.o] Error 1

I'm not sure if I actually did the git stuff correctly but the external offset sims turned up in the source code.
More
19 Feb 2017 02:40 #88227 by tommylight
I do not know why, but the error relates to the same file you got the error in git, namely control.c
More
19 Feb 2017 05:22 #88231 by rodw
I worked it out. I think there was a network timeout when I checked out the new branch so the file file was corrupt. I did a hard reset of the master branch and started again. This time it worked.


So now I've got the axis offset branch installed, I've run the demo sims but I still don't really understand what it is trying to demonstrate. I did see that it applied offsets, but how could we use it?

Sorry about the dump questions, but I want to follow through on this all seeing I started it!
More
19 Feb 2017 13:07 - 19 Feb 2017 13:08 #88264 by newbynobi
@rodw,

I think you have pulled the wrong branch. The one related to the bug fixes with simultaneous JOINT homing is:

dgarr/per_seq_homing

That branch will home simultaneous all joints with the same negative value. So if you put in your INI File to a XYYZ config the home sequence value to both Y-Joints "-2" they will be tight together. So it does not matter, if you start homing the first or the second Y joint, LinuxCNC will take care to home both simultaneous.

You can watch that with halshow, watching the joints homing state.

Norbert
Last Edit: 19 Feb 2017 13:08 by newbynobi.
More
19 Feb 2017 23:11 #88309 by rodw
Norbert, thanks but I want them both :)

I have to work out how to merge branches yet.

When I had a look at Dewey's source, it looked like he had incorporated you gmocappy revisions already. Anyway with the offset branch working, the homing buttons was disabled.
More
19 Feb 2017 23:46 #88311 by BigJohnT
Yea Dewey will merge that branch with master to keep it up to date with changes in master until he merges that branch back into master.

JT
More
27 Feb 2017 18:48 #88694 by newbynobi
@rodw,

the branch per_seq_homing has been merged to master.
Could you please test, if the changes of gmoccapy do fit your needs?

Norbert
More
27 Feb 2017 20:19 #88704 by rodw
Norbert, thanks. I recompiled master and checked the homing. Everything seems OK now. Thank you for taking this problem on board and resolving it for me. I;m going to update the thread title to solved.

Also please pass on my thanks to Dewey.
More
05 Mar 2017 16:25 #89044 by newbynobi
Hallo rodw,

I needed to change some code, as my changes destroyed some other parts of linuxcnc.
I will push in a few minutes. So please take care if you get the next update. IMHO it should work as expected. I want to make some more changes and enable again the HOME_Y button, as the sequential homing branch has been merged in master.

Just take care your Y axis (both) has the same negative home sequence!


Norbert
Moderators: newbynobi
Time to create page: 0.176 seconds
Powered by Kunena Forum