Umbuntu precise update to Linuxcnc 2.7 errors

More
10 years 8 months ago #70699 by gizmo6023
I had a copy of wheezy installed but it insisted on locking me out with parallel port errors so I have reverted to Precise.
I am attempting to follow the instructions to upgrade but keep getting dependency errors:

linuxcnc.org/docs/2.7/html/getting-start...etting-linuxcnc.html

6. Install the RTAI kernel and modules by running

sudo apt-get install linux-image-3.4-9-rtai-686-pae rtai-modules-3.4-9-rtai-686-pae

The following packages have unmet dependencies:
linux-image-3.4-9-rtai-686-pae: Depends: kmod but it is not going to be installed or
module-init-tools but it is not going to be installed
Depends: linux-base (>= 3~) but it is not installable
Depends: initramfs-tools (>= 0.99~) but it is not going to be installed or
linux-initramfs-tool
Recommends: firmware-linux-free (>= 3~) but it is not installable
E: Broken packages

Linux is a new language to me so I may be missing something obvious.
I have copy pasted the first 5 items into the terminal window and software sources tab and everything seemed to work without errors.

Please Log in to join the conversation.

More
10 years 8 months ago #70738 by gizmo6023
Ok, I sorted out the upgrade issues I now have 2.7.

Please Log in to join the conversation.

Time to create page: 1.556 seconds
Powered by Kunena Forum