2.9.5 should not be available to download due to it being broken.

More
1 year 5 days ago #337166 by andypugh
2.9.6 is also broken.
And 2.9.5 and 2.9.6 only exist because 2.9.4 is broken.
As it 2.9.3, 2, 1, 0....

As far as I know at the moment 2.9.7 is, at least, broken in unknown ways.

It will be out on Sunday.

Please Log in to join the conversation.

More
1 year 5 days ago #337173 by unknown
Any idea of what may be suitable for a new image ?

I'd like an idea of what to use in the Raspios image I'm working on for Trixie.

Please Log in to join the conversation.

More
1 year 5 days ago #337181 by Aciera


Any idea of what may be suitable for a new image ?

2.9.7

Please Log in to join the conversation.

More
1 year 3 days ago #337274 by rodw
DO we actually need an image anymore of the Pi is using Trixie? Why not just try one of the official Deb files here?
linuxcnc.org/dists/trixie/2.9-uspace/binary-arm64/

Please Log in to join the conversation.

More
1 year 3 days ago #337275 by unknown
I think those Trixie files may have been built on Bookworm, when I built an image last night it pulled the Linuxcnc packages from Debian. Trying to manually install brought up a lot of messages regarding packages that could not be installed.
Code:
sudo apt install linuxcnc-uspace=1:2.9.6 linuxcnc-uspace-dev=1:2.9.6 Solving dependencies... Error! Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: Unsatisfied dependencies: linuxcnc-uspace : Depends: python3 (< 3.12) but 3.13.5-1 is to be installed Depends: libboost-python1.74.0 (>= 1.74.0+ds1) but it is not installable Depends: libboost-python1.74.0-py311 but it is not installable Depends: libgpiod2 (>= 1.5.1) but it is not installable Depends: libpython3.11 (>= 3.11.0) but it is not installable Recommends: hostmot2-firmware-all but it is not installable Error: Unable to correct problems, you have held broken packages. Error: The following information from --solver 3.0 may provide additional context: Unable to satisfy dependencies. Reached two conflicting decisions: 1. linuxcnc-uspace:arm64=1:2.9.6 is selected as an upgrade 2. linuxcnc-uspace:arm64=1:2.9.6 Depends python3 (< 3.12) but none of the choices are installable: [no choices]

Please Log in to join the conversation.

More
1 year 3 days ago #337326 by rodw
Thars a shame, So much going on in the builds and repos

Please Log in to join the conversation.

More
1 year 3 days ago #337341 by unknown

Please Log in to join the conversation.

More
1 year 2 days ago #337388 by rodw

Aye, that it is.
Andy is working hard on this, He's got a longer key now for trixie. you could try this script he did for trixie
www.linuxcnc.org/linuxcnc-trixie-install.sh
But he wants to produce a singe script that does all Debian versions....

Please Log in to join the conversation.

More
1 year 1 day ago #337391 by unknown
The image builds with the longer Trixie key, I've also migrated to the newer form for the sources list.
The only package that will update from the Linuxcnc repo are the docs. So it works, the only issue being the one mentioned in my previous post.

Please Log in to join the conversation.

More
1 year 22 hours ago #337471 by rodw
I think you need a preferences file to pin the linuxcnc repo files in /etc/apt/preferences.d that looks something like
github.com/LinuxCNC/linuxcnc-live-build/...c-uspace.pref.chroot

Please Log in to join the conversation.

Time to create page: 0.339 seconds
Powered by Kunena Forum