Axis Modifications

More
30 Aug 2016 18:12 #79735 by skunkworks
skunkworks replied the topic: Axis Modifications
I am having an odd issue related to (ti seems) jessie and Gome/cinnamon.

Axis opens minimized it seems - or at least you cannot see it. It shows up in the task bar and you can alt-tab to it. (or click on the task bar )

I have tried all the above. It effects the size of axis - but axis still isn't visible until you click on the task bar or alt-tab to it.

Couple of things
-axis seems to be the only gui that shows this behavior.
-I also have mate installed - axis opens normally.

sam
More
30 Aug 2016 19:41 - 30 Aug 2016 19:47 #79741 by Todd Zuercher
Todd Zuercher replied the topic: Axis Modifications
Not sure, maybe an OpenGL problem.

I have LMDE with the Cinnamon desktop installed in a VM and Linuxcnc/Axis is not having those problems for me.

However I have done a few RIP installs of Linuxcnc from source on that VM, so it has had a lot of dependency stuff installed to it that a fresh install from binaries probably wouldn't have..
Last Edit: 30 Aug 2016 19:47 by Todd Zuercher.
More
30 Aug 2016 19:49 #79742 by skunkworks
skunkworks replied the topic: Axis Modifications
This is 2 different systems.. My laptop which I have been running for months with jessie/mate - and a fresh install of jessie running cinnamon right out of the box (matsuura). I installed cinnamon on my laptop to see if that acted the same and it did. I just tried for grins booting a 3x non-realtime kernel - same deal. It is just odd.

sam
More
30 Aug 2016 19:59 #79743 by tommylight
tommylight replied the topic: Axis Modifications
Most probably as Todd noted, an openGL problem. This is especialy true if using newer nvidia graphic cards. Install Blender ( via synaptics or terminal, it is in repos ), start it and if you get a transparent screen with nothing in it, you do have an nvidia card.
Real time kernels do not like nvidia proprietary drivers so install them only if you need sim, otherwise try software rendering. It is docuemnt in wiki.
More
30 Aug 2016 20:29 #79749 by skunkworks
skunkworks replied the topic: Axis Modifications
heh - let me explain.

Axis runs just fine on both systems. (am running rt_preemt and uspace with mesa hardware)

The problem is with gnome/cinnamon when axis is first launched it doesn't show up. It is running - just looks minimized. I can alt-tab to it or click on the task bar to bring it up.

sam
More
30 Aug 2016 20:43 #79753 by tommylight
tommylight replied the topic: Axis Modifications
Oh that, well i have never seen that ! :)
From how you explain it, it might have something to do with the window manager in Cinnamon. But i have nothing more. Blank!
More
24 Jan 2017 04:16 #86533 by thehammertownhead
thehammertownhead replied the topic: Axis Modifications
I am running Axis 2.7.8.

I found the axis.tcl located in
/usr/share/axis/tcl/
I've made some modifications to it....I'd like to change the source...

Where can I find the axis.py?
More
23 Apr 2017 10:39 #91878 by massimodamassa
massimodamassa replied the topic: Axis Modifications
Hi everyone, I'm sorry I'm not a computer programmer but I like to try to modify things. I managed to get the axis.tcl file to zoom in the jog buttons, but I find it hard to figure out where to change the values.
Since all the original Axis GUI is all right, and since the machine controls the whole thing with external buttons, I'd like to eliminate what's missing.
Is there anyone who can explain how to intervene?
Is there any IDE that interprets the code so you can grab it graphically?
Thank you for your suggestions.
Attachments:
Time to create page: 0.123 seconds
Powered by Kunena Forum