command format problem

More
17 Jan 2016 06:04 #68568 by cmorley
HAL pins work like this;

a driver pin , a signal name, a driven pin or pins
a signal can only have one driver pin but can have many driven pins

motion.in-position is the driver pin , in_pos is the signal and the classicladder input pins are the driven pins.
More
17 Jan 2016 06:07 #68569 by wl888
the fact you have in_pos sent to classicladder multiple times seems wrong all by it's self.
yep..tried that..but 4,5,6,7 all show true on the hal meter
the hal meter recognizes the button press, but that's it.

You should be able to use the one input for all the logic that requires it.
sorry Chris..could you dumb that down please

I still have several other command lines that need to be laddered as well.

thanks
Doug
More
17 Jan 2016 06:13 - 17 Jan 2016 06:14 #68570 by wl888
do you meam this??
net motion.in-position in_pos => classicladder.0.in-04

and
can i use that no matter what the action i am asking for is?..ie g0 x0y10 or g38...
Last Edit: 17 Jan 2016 06:14 by wl888.
More
17 Jan 2016 06:28 - 17 Jan 2016 06:29 #68571 by cmorley
yes that gives you the in position flag to classicladder, then use that classicladder input to all MDI commands.

there is no need to bring the same information multiple times into classicladder.
Last Edit: 17 Jan 2016 06:29 by cmorley.
More
17 Jan 2016 06:32 #68572 by wl888
ok trying that now
More
17 Jan 2016 07:03 #68575 by wl888
OK..put that in but i thinks the front section is reversed, got an error( error message attached)

reversed front section to match line 21. as this section worked.

net in_pos motion.in-position => classicladder.0.in-02
#22
#23
#Laser offset setup
# set to mdi mode
#net mode halui.mode.is-mdi => classicladder.0.in-04
# wait for motion to finish
net in_pos motion.in-position => classicladder.0.in-04
net in_pos motion.in-position => classicladder.0.in-05
net in_pos motion.in-position => classicladder.0.in-06
net in_pos motion.in-position => classicladder.0.in-07
#32
that got rid of the error but still no action on the button
?is "motion.in-position " the correct command for what i wish to do?
I looked thru that area and was none the wiser.

fresh copy of file attached
thanks
Doug
Attachments:
More
17 Jan 2016 07:15 #68576 by cmorley
Try this file.
Attachments:
More
17 Jan 2016 08:13 #68577 by wl888
sorry for the delay in getting back to you, i was looking for examples that i might have missed, no luck.

tried your file, no errors, but no actions.

this is proving to be quite challenging, its odd that i can't find an example of something similar, this must have been done before.

thanks
Doug
More
17 Jan 2016 19:45 #68611 by cmorley
Do you understand how this collection of code works?
Can you see in classicladder that it is working as it should?
You must trace the signals to see where the action is not right.
IIRC the pyvcp button connects to classicladder that will connect to a halui MDI command.
Then classicladder will wait for the in_pos command and do something else.

There are different new ways to do this now - GLADEvcp but it still should work the way you are doing it.
Also posting your whole config would help for anyone interesting in understanding what and how you are doing.

Chris M
More
17 Jan 2016 22:39 - 17 Jan 2016 23:00 #68629 by wl888
Full files attached.
No I don't understand most of this as i am new to linuxcnc in general, i have put together what i believe should work from other examples i have found, and yes i agree it looks correct, the hal meter even shows some of the connections responding, but it still doesn't carry out the the steps asked for, which is strange because the Z touchoff section, which the rest of my code is reflecting works.
The hal meter shows a responce for the top 3 buttons when pressed this also shows for the classicladder.0.00 03 and 08 which are the buttons.
I have dabbled with Glade but there must be a way to get this to work in classicladder, it seams to be straight forward but it just doesn't run.
I have attached the full config.
What else can i do??
Doug
Attachments:
Last Edit: 17 Jan 2016 23:00 by wl888.
Time to create page: 0.573 seconds
Powered by Kunena Forum