Monostables stop working?

07 Jul 2016 19:07 #77158 by PCW
What PC hardware do you have? also what kernel and Ethernet chip?
for kernel:

uname -a

for Ethernet

dmesg | grep -i ether

1 KHz should be ok on most any PC, but there may be hardware specific tweaks needed
08 Jul 2016 12:29 #77174 by jeeybee
Some quotes from this thread when I worked with the kernel:

Now I get 28207ns after one hour of youtubing in latency test

I updated to Preempt-RT kernel 4.1.5 and that solved the most of my problems in that thread

Processor 1037u, intel 1,8ghz dual core
Realtek RTL8111E 10/100/1000 Controller
chipset INTEL NM70
intel HD graphics
08 Jul 2016 17:33 #77190 by jeeybee
I have some other chipsets to try also for my next project, which would you prefer:
i3 3217u, J1900 or J1800?

I saw in the other thread that you (pcw) had some succes with J1800.
08 Jul 2016 18:01 - 08 Jul 2016 18:01 #77192 by PCW
In general my experience with Preempt-RT is the faster, the better
so J1800/1900 ok for 1 KHz servo thread with Ethernet
probably the J1900 is a bit better

The I3 3217 is probably similar to the J1900.

If you need to run a fast servo thread over Ethernet, say for torque mode drives or similar uses,
I would choose something like a G32XX CPU and a H81 or H97 based motherboard
These can do 4 KHz servo threads reliably
Last Edit: 08 Jul 2016 18:01 by PCW.
08 Jul 2016 18:14 #77193 by jeeybee
Ok thanks.
Its a bit limited with the industrial(ish) mini computers I use (thats the hole point for me to work with the ethernet device and minicomputer, otherwise I could just as well buy a stationary computer and use pci)
I think I will buy one j1900 and one I3 and see which one is best, I can always use the others for windows based software.

How about RAM, does it matter much in this case? I have 2GB in this.
08 Jul 2016 18:22 #77195 by PCW
I dont think RAM matters much as long as the big RAM users like the GUI have enough

Cache size does seem to affect network latency though (bigger is better)
10 Jul 2016 19:49 #77263 by jeeybee
Ok thanks.

Is it possible to turn off the latency error message?
10 Jul 2016 20:37 #77264 by PCW
Not without changing the source

Can you watch servo-thead.tmax to see how bad the latency really is?

Did you disable all power management/ speedstep/turbo speed options in the BIOS?
22 Aug 2016 10:14 #79242 by jeeybee

Changed to a J1900 computer and problem solved, no problem with 1000000 servo thread now.

Thanks the tips!
Time to create page: 0.140 seconds
Powered by Kunena Forum