Problems using plugin PCI parallel port as main IO.

07 Nov 2016 11:33 #82533 by Mouse

"unresponsive" what did you mean?

The stepper drivers receive no signal indicating the parallel port is not giving an output when running Linux CNC.
I am using the same LinuxCNC setup with the only change being the address of the port. So all being well the machine should work if the port address is correct however as you suggest something goofy might be going on.

I am considering connecting up some LEDs direct to the parallel port and some test code to flash them as a next move on diagnosing the problem.
07 Nov 2016 13:03 #82540 by andypugh
Try running the config apps/parport, that is a simple parallel port tester.
You will need to edit the HAL file and restart to change the base address.
07 Nov 2016 15:55 #82547 by Mouse
Could not find config apps/parport, however used ptest from here which appears to do the same sort of thing.

SUCCESS!! It lights a LED straight from the back of the PC connector :) but not at the stepper driver :(
Working address of the PCI card was 0x1008

The problem actually appears to be the opto isolator board, a DB25-1205, that is giving the problem. At least I can stop blaming the PC and concentrate on the isolator area now.

I won't comment about both sides of the optical isolator board being connected together to run from the same 5V power supply and the effectiveness of it still acting as an isolator.

I'll post an update when we get the thing running again.

Thanks for the pointers and rapid advice,
14 Jan 2017 08:43 #85731 by Imre
Hi Guys!
I have also problem with my parallel port. I have linuxcnc 2.7 weezy. And i use MCS98xx Plug in PCI parallel card.
The card worked well on windows 7 . (The reason of change: I have some problem with mach3)

Result from ./ppdiag.txt

imi@imi:~/Asztal$ ./ppdiag.txt

You are not runnig this script as 'root'. Only a few checks will be done.
No configuration update will be done.

S01: parport built as module

S02: parport0:
S02: ADDR :0x378
S02: IRQ :7
S02: DMA :no DMA used
S02: parport1:
S02: ADDR :0x2020
S02: IRQ :21
S02: DMA :no DMA used

grep: /etc/modules.conf: Nincs ilyen fájl vagy könyvtár
S03: no parport parameters

S10: ppdev built as module

S12: /dev/parport0 exists ...
S12: ERROR /dev/parport0 is not readable!
S12: ERROR /dev/parport0 is not writable!
S12: /dev/parport1 exists ...
S12: ERROR /dev/parport1 is not readable!
S12: ERROR /dev/parport1 is not writable!

successfull end ....

Result from lspci -vv

03:07.0 Communication controller: NetMos Technology PCI 9835 Multi-I/O Controller (rev 01)
Subsystem: LSI Logic / Symbios Logic 1P2S
Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Interrupt: pin A routed to IRQ 21
Region 0: I/O ports at 2030
Region 1: I/O ports at 2028
Region 2: I/O ports at 2020
Region 3: I/O ports at 2018
Region 4: I/O ports at 2010
Region 5: I/O ports at 2000
Kernel driver in use: parport_serial

i found a how to install pdf for MCS98xx card.
I tried to follow steps but no result. I think some command not correct in my case.
for example:

# modprobe parport_pc io=0x378,0x9800 irq=4,18

I tried it # modprobe parport_pc io=0x378,0x2020 irq=4,21
but i think i dead in details because i very beginner in linux.
What can i do? Please help me!
15 Jan 2017 01:28 #85800 by tommylight
Delete the modprobe line and under it should be "loadrt paraport "0" "
the address of your port is 2020, but just put a 0 there so it finds it by itself.
If you have an onboard and an add on, then use the 0x378 and 0x2020 in the same line.
18 Jan 2017 16:43 #86062 by Imre
Thank you for the answer. I have no onboard port, only PCI plug in card(...and one port on it). I think too, i have problem with address. Could you write to me an example how can i fix it? I looked for solution on the internet, but no result. Something always wrong.
18 Jan 2017 16:51 #86063 by tommylight
Start the stepconfig from the menu, on the third screen near the botom you have "parallel port address" and "0x378" already writen, delete 0x378 and put 0 ther, move on to next screen and put in the settings for your machine, and test each axis.
18 Jan 2017 17:08 #86066 by Imre
Oh, so that does not matter how parport tester does not working?!?! ( )
I connect my pc to the cnc tomorrow and try it.
Thanks for the really fast answer!!
19 Jan 2017 23:21 #86210 by Clive s
Sorry to hijack the thread but quick question. I am running 2.7.8 and trying to check a second pci pp card.

I am trying to use the pp tester as above I have put the two files into the same directory and from a terminal typed halrun -I -f ptest.hal but can't get it to run.

Does the terminal have to be opened from the same spot as the files? Thanks
19 Jan 2017 23:42 #86212 by tommylight
Yes it does.
You do not need the tester, but it is nice to play with and test. Still you need the right address to test the port you want.
sudo lspci -v
that is one way of finding the right address, or use stepconfig and select two parallel ports, enter 0 for the first and 1 for the second.
If you want to manualy edit the hal and enter address there, you will need to also add the read and write to the base thread for that port.
The following user(s) said Thank You: Clive s
Moderators: PCWjmelson
Time to create page: 0.192 seconds
Powered by Kunena Forum