[SOLVED] Rebuilding master broke Mesa hm2_eth

18 Feb 2017 21:46 - 18 Feb 2017 23:23 #88191 by rodw
I reinstalles Linixcnc master this morning to get a new version of gmocappy after Norbert fixed a bug I found.
I had to make it using sudo and this casued some permissions issues which I resolved.

Using run in place, Linuxcnc fails when loading hm2_eth as follows:
m2: loading Mesa HostMot2 driver version 0.15
hm2_eth: loading Mesa AnyIO HostMot2 ethernet driver version 0.2
libkmod: ERROR ../libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/8192cu.conf line 2: ignoring bad line starting with '/sys/bus/usb/drivers/rtl8192cu/new_id'
modprobe: ERROR: could not insert 'ip_tables': Operation not permitted
iptables v1.4.21: can't initialize iptables table `filter': Table does not exist (do you need to insmod?)
Perhaps iptables or your kernel needs to be upgraded.
hm2_eth: ERROR: Failed to create iptables chain hm2-eth-rules-outputhm2_eth: WARNING: Unable to restrict other access to the hm2-eth device.
This means that other software using the same network interface can violate
realtime guarantees.  See hm2_eth(9) for more information.
hm2_eth: Hardware address: 00:60:1b:10:40:6c
ioctl SIOCSARP: Operation not permitted
hm2_eth: rtapi_app_main: Operation not permitted (-1)
./my_LinuxCNC_machine.hal:22: waitpid failed /home/plasma/linuxcnc-dev/bin/rtapi_app hm2_eth
./my_LinuxCNC_machine.hal:22: /home/plasma/linuxcnc-dev/bin/rtapi_app exited without becoming ready
./my_LinuxCNC_machine.hal:22: insmod for hm2_eth failed, returned -1
Shutting down and cleaning up LinuxCNC...
Running HAL shutdown script
hm2: unloading

The bad conf file is to do with my USB wifi installation and id based on this link

So my copy of LCNC is broken and I can't work out how to fix this. It worked before the upgrade.
Last Edit: 18 Feb 2017 23:23 by rodw.
18 Feb 2017 22:11 #88193 by rodw
I found that
rmmod 8192cu
Removes the wifi driver and allows Linuxcnc to start
But it would be nice to have internet
18 Feb 2017 22:26 #88194 by rodw
I deleted the problematic .conf file and the problem went away and Wifi is back on again. I suspect Linux Mint supports my driver natively.
18 Feb 2017 22:32 #88196 by rodw
Ooops, spoke too soon. Still have the issue
18 Feb 2017 22:48 #88201 by cncnoob1979
Sounds like you are having a bad day!

As far as linuxcnc is concerned all the "program" and files therein should be only in your RIP. Have you tried to do a new git pull with linuxcnc-dev1 or another name and try another rip? The rip is self contained and should not have a bearing on your issue.

The wifi driver problem is interesting.. Are you having a problem with linux mint loading the wrong driver or two drivers at the same time?
18 Feb 2017 23:22 #88204 by rodw
cncnoob, thanks your advice on the other thread helped me solve this. I took ownership of all my home directory content from root, did a make clean and another make and it is all working again. Now only if I could get the last 5 hours of my life back!

I could not understand why rebuilding lcnc broke internal stuff. I have no idea how root got ownership in the first place.
18 Feb 2017 23:26 #88205 by cncnoob1979
My thought would be that since the build process is in your home folder, the process generated the files with root ownership therefore taking permissions from you and making them root.

Yeah, sudo in root folder has given me fits before... I have done clean installs because I messed up building software and it was much easier to just start again. Glad you go it going!
The following user(s) said Thank You: rodw
19 Feb 2017 00:39 #88209 by PCW

I had to make it using sudo and this casued some permissions issues which I resolved.

This can cause endless pain and suffering

I dont think there is ever a reason to build a RIP version of LinuxCNC as root
(other than the make setuid part)
19 Feb 2017 01:15 #88216 by rodw

PCW wrote: This can cause endless pain and suffering

It did that!

PCW wrote: I dont think there is ever a reason to build a RIP version of LinuxCNC as root
(other than the make setuid part)

Yes, I don't understand why root had stolen my permissions which prevented me from running make in the first place. Anyway, its fixed now!
12 Mar 2017 11:55 #89462 by jCandlish
For some silly reason hm2_eth thinks it is a network administer, and plays with ipv6 settings and iptables, in a very non-robust manner.

Moderators: PCWjmelson
Time to create page: 0.151 seconds
Powered by Kunena Forum