running axis on SIM and Step Configuration Wizard

More
19 Jul 2009 19:53 #582 by Gyuri100
I am evaluating EMC2 for a potentially complicated machine that starts with a precision XYZ system using 5-phase steppers and nanostep drives. I am still working on the machine and its electronics so, my experience (very limited) with EMC is in the realm of the SIM. I downloaded, checked (OK) and installed the .iso CD, as recommended. I can run all the DISPLAY modules except for axis, it just locks up ("no file" on the banner) and I have to restart box. The same is happening with the Step Configuration Wizard.
I am a total beginner in Linux, just bought the UBUNTU unleashed book and fighting to undersand its syntax and morphology. The box I am using for this has no Ethernet card so the only way to upgrade for me is by download and I could not figure out how to do that.
Please, can anybody help?
George

Please Log in or Create an account to join the conversation.

More
20 Jul 2009 11:47 #595 by BigJohnT
For the download part I can help with that. You have to download the .deb file. Then copy it to the other computer and usually you can single or double click on the file and it will install.

www.linuxcnc.org/docview/html//common_Getting_EMC.html#r2_7_1

John

Please Log in or Create an account to join the conversation.

More
21 Jul 2009 00:23 #601 by Gyuri100
Thanks BIgJohnT, I did look up the .deb files......my problem now is that those files were released in January and I did download the software a few days ago. Should I consider that those updates are inctuded in my release? ......sometimes I feel so helpless; I think my idosyncrasies geenerated by my former experiences makes me overly cautious...can you advise? ...please!
George

Please Log in or Create an account to join the conversation.

More
21 Jul 2009 00:52 #602 by mozmck
Hi George, here is the main file you'll need - updated July 5:
linuxcnc.org/hardy/dists/hardy/emc2.3/bi.../emc2_2.3.2_i386.deb

If you need the development stuff - for building components for example; you'll need this file and all of the packages it depends on:
linuxcnc.org/hardy/dists/hardy/emc2.3/bi...2-dev_2.3.2_i386.deb

If you need the amd64 packages they are in this directory:
linuxcnc.org/hardy/dists/hardy/emc2.3/binary-amd64/

Hope that helps!
Moses

Please Log in or Create an account to join the conversation.

More
21 Jul 2009 02:04 #603 by Gyuri100
Thanks Moses, - can you hold my hand just a little bit more?
I did download the files, Had no problem installing the main 2.3.2 file but the dev gave me: "Error Dependency is not satisfiable: g++" I also tried to run the axis; it shows the new version; but I do have a big black dot :( it is new that I can move it around) but I still have to restart the computer to get out of there. The title (banner) is:
"Axis 2.3.2 on EMC-Hal-Sim-Axis (no file)" I did launch it also using an ini file that works witht kemc just fine (as much as I can tell)
George

Please Log in or Create an account to join the conversation.

More
21 Jul 2009 02:48 #604 by mozmck
Yeah, there are a number of other packages you will need for the dev. I wouldn't install it unless you need it, and right now it sounds like you just need to get something running. I don't know why axis doesn't run correctly. One thing you might try is make sure that Visual Effects are turned off. Go to the menu System->Preferences->Appearance and the last tab in the dialog that comes up should say "Visual Effects".

If you can get on IRC you might can get some quicker and more interactive help there.

Please Log in or Create an account to join the conversation.

More
22 Jul 2009 00:29 #607 by Gyuri100
Thanks Moses,
The visual effects are: none. I will try to follow your advise and go to IRC...I do not have a client yet (yes...the idiosyncrasies..hmm.. am I inventing here an English word?) but I will jump the water.
Thanks again, George

Please Log in or Create an account to join the conversation.

More
22 Jul 2009 02:18 #608 by mozmck
One other thing you can do is try to run glxgears.

In a terminal window just type: glxgears and hit enter. It should bring up a window with some colorful gears turning in it. If it doesn't then there is probably something wrong with your opengl. If you can get on IRC people can step you through debugging a lot quicker.

Please Log in or Create an account to join the conversation.

More
22 Jul 2009 11:10 #609 by BigJohnT
If you go to the Community page there is an embedded java client for the IRC.

John

Please Log in or Create an account to join the conversation.

More
23 Jul 2009 01:55 #610 by Gyuri100
Before I go to the wide world....I did some testing: Downloaded, burned the .iso disk again and reinstalled the whole thing (surprize: this time the axis is the last stable edition: 2.3). The situation is largely the same: I can run from the Applications>emc2>sim the tkemc; the mini, but the axis is still freezing up on me. So I restarted...what else?...and run the axis from the terminal as:
axis -ini /home/........../sim/axis.ini
I get an error:
Traceback (most recent call last):
File "/usr/bin/axis", Line 3647, in <module>
s.poll()
emc.error: emcStatusBuffer invalid err=3

I repeated the same with the first instalation disc (version 2.2) with exactely the same result.
So this ca not be a random error....is something systematic here ...but what?
The box has an 700MHz Athlon processor, 348M ram (tested for an hour and no errors) and 6.4G HDD
:S George

Please Log in or Create an account to join the conversation.

Time to create page: 0.077 seconds
Powered by Kunena Forum