Rt component BIQUAD Bug ?

More
09 May 2014 02:20 - 09 May 2014 02:26 #46733 by gaston48
Hello everyone
I have a problem with the rt component BIQUAD

It crashes linuxcnc 2.5.4 when biquad is enable.

Could someone check if this is a bug of biquad ?
thank you very much


Attachments:
Last edit: 09 May 2014 02:26 by gaston48.

Please Log in or Create an account to join the conversation.

More
09 May 2014 06:09 #46742 by andypugh
Replied by andypugh on topic Rt component BIQUAD Bug ?
Yes, definitely a bug. Hard to see what, but I tried it, and crashed my dev PC badly several times.

If you feel inclined to try to fix it, then I think that the problem will only be evident in the pre-processed C-file.
I might find time to look at it, and another Dev is having a look too, so there might be a fix before morning.

Thanks for the report.

Please Log in or Create an account to join the conversation.

More
09 May 2014 12:07 #46746 by seb_kuzminsky
I just pushed a fix for this problem to the 2.5-comp-fix branch at git.linuxcnc.org, please give it a try if possible.

Please Log in or Create an account to join the conversation.

More
09 May 2014 22:07 #46762 by seb_kuzminsky
The fix got merged into the 2.5 branch. It'll be in version 2.5.4.13.g938881f (available from the buildbot any minute now).

The bug you found has been preventing the biquad component from working since 2007, and no one noticed until now. You are using code that hasn't seen wide use and testing. Please let us know how it works for you.

Please Log in or Create an account to join the conversation.

More
10 May 2014 00:25 #46770 by gaston48
Replied by gaston48 on topic Rt component BIQUAD Bug ?
Hello Andy, hello Sebastian!
thank you for your response

I was a little long, he had to learn :blush: to download the sources and compile the new version.

I tested a low-pass biquad type 1 with auto coefficient calculation and the same type 0 biquad low pass with coefficient calculation by me .

operation is perfect !

I tested this filter in a special configuration with multi-encoders and servo
(inspired by gear cuting of Andy)

Thank you very much !!

Please Log in or Create an account to join the conversation.

More
10 May 2014 02:05 #46774 by seb_kuzminsky
Glad to hear it's working now! Thanks for the bug report. :)

Please Log in or Create an account to join the conversation.

Time to create page: 0.138 seconds
Powered by Kunena Forum