Gmoccapy feed on screen

More
24 Feb 2018 15:44 #106433 by Mike_Eitel
I must overlook something
But in none of the applications i can see the figure F xxx showing something else than 0

All sliders work fine and speed of motion changes as expected.
But nothing ever changes the value behind the letter F.

What hal pin i have to connect?

THX
Mike

Please Log in or Create an account to join the conversation.

More
24 Feb 2018 16:32 #106434 by newbynobi
Replied by newbynobi on topic Gmoccapy feed on screen
Hallo Mike,

you do not need to connect an hal pin.

Go to the MDI Tab and enter F1000

What does the display now show?

Norbert

Please Log in or Create an account to join the conversation.

More
24 Feb 2018 16:57 #106435 by Mike_Eitel
Replied by Mike_Eitel on topic Gmoccapy feed on screen
0
I'm on latest master. Not sure if i have seen in earlier days.

I use midi and a also program that ramps up Fxxx.
I tried also in a fresch pncconf . Or your demo. A sim . .. None ever shows any value.
Is there a parameter to set?

I think it should be connected to motion.requested.vel
Mike

Please Log in or Create an account to join the conversation.

More
24 Feb 2018 18:27 - 24 Feb 2018 19:38 #106437 by Mike_Eitel
Replied by Mike_Eitel on topic Gmoccapy feed on screen
I just remarked that also in the gcode parameter window F is shown as zero 'speed'
But interpreter reacts correct.

THX
Mike
Last edit: 24 Feb 2018 19:38 by Mike_Eitel.

Please Log in or Create an account to join the conversation.

More
24 Feb 2018 20:56 #106457 by newbynobi
Replied by newbynobi on topic Gmoccapy feed on screen
Here it is working, please post screenshot with mdi f500 send

Please Log in or Create an account to join the conversation.

More
24 Feb 2018 21:27 #106460 by Mike_Eitel
Replied by Mike_Eitel on topic Gmoccapy feed on screen
NOW it gets interesting.
MIDI F300 works but the following test program not:

feedtest.ngc
( test program to see Feed changing )
( msg, test feed configuration )
g21
#1000=100 ( loop 100 times )
#1100= 10 ( Start movment speed )
#1200= 500 ( Start spindle speed )
( this loop has delays after moves )
o300 while [#1000]
G0 X0 Y0
F#1100
S#1200
G1 X100 Y100
#1100 = [#1100 +100]
#1200 = [#1200 +100]
#1000 = [#1000 - 1]
o300 endwhile
( msg, DONE)
M2 (stop here)

IMAGE is while correct running program ;-(

THX Mike
Attachments:

Please Log in or Create an account to join the conversation.

More
24 Feb 2018 22:03 #106462 by newbynobi
Replied by newbynobi on topic Gmoccapy feed on screen
F value is read ahead, your programm has finished reading ahead, before your programm even starts moving.

I will check your code on my machine tomorow.

Norbert

Please Log in or Create an account to join the conversation.

More
24 Feb 2018 22:09 #106463 by Mike_Eitel
Replied by Mike_Eitel on topic Gmoccapy feed on screen
Ok,
So you think when i use one of my programs that are generated by cam, fx. mastercam, i will see these feedrates. I will give it a try and let you know.
Good night.
Mike

Please Log in or Create an account to join the conversation.

More
24 Feb 2018 22:16 #106464 by Mike_Eitel
Replied by Mike_Eitel on topic Gmoccapy feed on screen
OK

I attach a small MASTERCAM generated one.
Only the first F command is shown, than it goes back to F 0 and stays that way.

File Attachment:

File Name: MECCR_MCAM...PFEN.ngc
File Size:74 KB
Attachments:

Please Log in or Create an account to join the conversation.

More
25 Mar 2018 10:03 #107802 by newbynobi
Replied by newbynobi on topic Gmoccapy feed on screen
Hallo,

I just checked your sample file. And the read ahead does cause the "feed display" problem. There is some work going on a branch called "statetags" to solve the read ahead problem.

So no solution for now.

Norbert
The following user(s) said Thank You: Mike_Eitel

Please Log in or Create an account to join the conversation.

Moderators: newbynobi
Time to create page: 0.082 seconds
Powered by Kunena Forum