Setting up lathe speed with 7i76 digital pot

More
30 Dec 2018 14:02 #123147 by Stigoe
I'm still working on retrofitting my lathe into CNC with PathPilot and my latest struggle is getting speed adjustments to work, so I'm here hoping for some hand-holding... :-)

Attached are my current ini and hal-files. Beware, they are a work in progress...

I'm planning to connect up 7i76's built-in digital pot to the speed controller of my lathe, but I don't think I have managed to set it up properly. As it is now, when I check .spinout, I get the currently selected RPM, which I guess is not correct?

Anyone see any glaring mistakes in my files, especially when it comes to spindle speed and spindle encoder?

Br,
Stig
Attachments:

Please Log in or Create an account to join the conversation.

More
30 Dec 2018 15:22 #123152 by pl7i92
can you tell here what the VFD od the Spindle interface requirers
spindle+ is 12V from VFD
spindle -is DCM of the VFD Spindle controller
and the Spindel out goes to the 0-10V or VI input thats all

Please Log in or Create an account to join the conversation.

More
30 Dec 2018 15:36 #123157 by PCW
Yes, blah.blah.blah.spinout should equal commanded RPM.

Main glaring thing I see at first glance is that blah.blah.blah.spinena is not connected
so you can never get any analog spindle voltage.
The following user(s) said Thank You: Stigoe

Please Log in or Create an account to join the conversation.

More
30 Dec 2018 15:40 - 30 Dec 2018 15:54 #123159 by PCW
Oops never mind its in another hal file

I would check the values of all the spindle related hal pins during operation
to verify that they have correct values (starting with the hardware pins and working backwards)
Last edit: 30 Dec 2018 15:54 by PCW.

Please Log in or Create an account to join the conversation.

More
30 Dec 2018 15:51 #123160 by Stigoe
pI7i92: I plan to replace the pot on the speed controller with the digital pot from the 7i76, so the speed controller will supply the voltage for this. I measured the voltage across the existing pot and it is 5v.

PCW: Thanks. I haven't actually connected the 7i76 to the speed controller yet as I wanted to check if a speed command would give a reasonable signal out on the digital pot. I'll see if I can get it hooked up tomorrow. I need to heat up my workshop somewhat before I do it, as it is showing 3 degC on a thermometer on top of the lathe right now.

Stig

Please Log in or Create an account to join the conversation.

More
01 Jan 2019 11:43 #123260 by Stigoe
I connected up the digital pot from the 7i76 to the speed controller (a Chinese close of a KBMM-225 or something similar). I also replaced the the On/Off switch with a contactor powered through a relay controlled by Output 0 as a Spindle Enable.

I can start the spindle with M3, but any RPM changes aren't reflected in the speed of the spindle.

With the original speed pot (4k7 pot), I had 5.5v across the pot. With no pot connected, I have 11v and with the digital pot I have only 2.2v across. No matter what speed I command, I get 0.13v out from the digital pot. I also tried to put .spinena on the same line as .output-00 in case this had something to do with it, like this
From
net spindle-on tormach.spindle => hm2_5i25.0.7i76.0.0.spinena
net spindle-io-control motion.spindle-on => tormach.spindle-iocontrol hm2_5i25.0.7i76.0.0.output-00	 # Changed
to
net spindle-on tormach.spindle 
net spindle-io-control motion.spindle-on => tormach.spindle-iocontrol hm2_5i25.0.7i76.0.0.output-00 hm2_5i25.0.7i76.0.0.spinena		# Changed
No difference.

Anyone have any ideas what is wrong?

Stig

Please Log in or Create an account to join the conversation.

More
01 Jan 2019 14:52 #123270 by PCW
What are the values of:
hm2_5i25.0.7i76.0.0.spinena and hm2_5i25.0.7i76.0.0.spinout
when you have requested full spindle speed?

Please Log in or Create an account to join the conversation.

More
01 Jan 2019 16:35 #123274 by Stigoe
I changed the settings for .spinena back to how they were.

As long as spindle is On, .spinena is true.

I tried both in low and high gear (in PP) and the results are
Low: .spinout equals set RPM
High: Obviously my scale is not set correct, as my results are
RPM .spinout
200 145.3488
1000 726.7442
1800 1308.14

No change in actual RPM of the spindle in any of these tests.

Stig

Please Log in or Create an account to join the conversation.

More
01 Jan 2019 16:46 #123275 by PCW
If you only have 2.2V across the 7I76's digital potentiometer you wont get any output voltage. I suspect you will have to supply an external 10 or 12V power source for this to work since it appears that the motor controller cannot supply the couple mA that the 7I76's digital potentiometer requires. Beware that the potentiometer wiring on many low cost speed controls is _HOT_ = at line voltage potential so any external power supply
must be isolated (something like a wall wart may work)

Please Log in or Create an account to join the conversation.

More
01 Jan 2019 17:18 #123277 by Stigoe
So connect negative of the external psu to both speed controller (bottom of pot) and spindle- and positive to spindle+ ?

Please Log in or Create an account to join the conversation.

Moderators: cncbasher
Time to create page: 0.117 seconds
Powered by Kunena Forum