Help with install of probe basic with 2.9 on deb 11 bookworm

More
24 Jun 2022 10:31 #245766 by tim052
Hi

I've been having a ton of issues getting probe basic installed on debian 11 i've installed linux cnc does anyone have any tips on how to get this going. I've managed to clone the python 3 versions of probe basic but i am having issues getting all the dependencies install a lot of the packages are giving 404 errors and not install when in run through the various guides is anyone else having issues or does anyone know of an update to date guide how to get this working?

Please Log in or Create an account to join the conversation.

More
24 Jun 2022 11:25 #245771 by tommylight
Sudo apt-get update
Before trying to install usually gets rid of 404 not found errors.

Please Log in or Create an account to join the conversation.

More
24 Jun 2022 12:41 #245776 by tim052
Yeah i tried that a few times and no luck unfortunately

Please Log in or Create an account to join the conversation.

More
24 Jun 2022 14:34 #245789 by TurBoss
hello,

can you send the error messages ?



thank you

Please Log in or Create an account to join the conversation.

More
24 Jun 2022 14:43 #245790 by spumco
Have you tried the instructions/steps at the qtpyvcp page?

www.qtpyvcp.com/install/bullseye.html

Not to say this is foolproof, but I've been successful with this once or twice.

I've also been successful with MX21 & PB using the instructions under the qtpyvcp sub-forum.

Please Log in or Create an account to join the conversation.

More
25 Jun 2022 03:19 - 25 Jun 2022 03:31 #245838 by tim052
Following that guide is get a mass of package not found errors i also tried installing with aptitude but no luck with that either all this messing around with packages also seems to have broken my linux cnc install
E: Unable to locate package libepsilon1 E: Unable to locate package libgdal28 E: Unable to locate package libgeos-3.9.0 E: Couldn't find any package by glob 'libgeos-3.9.0' E: Unable to locate package libglew2.1 E: Couldn't find any package by glob 'libglew2.1' E: Unable to locate package libnetcdf18 E: Unable to locate package libopencv-calib3d4.5 E: Couldn't find any package by glob 'libopencv-calib3d4.5' E: Unable to locate package libopencv-contrib4.5 E: Couldn't find any package by glob 'libopencv-contrib4.5' E: Unable to locate package libopencv-core4.5 E: Couldn't find any package by glob 'libopencv-core4.5' E: Unable to locate package libopencv-dnn4.5 E: Couldn't find any package by glob 'libopencv-dnn4.5' E: Unable to locate package libopencv-features2d4.5 E: Couldn't find any package by glob 'libopencv-features2d4.5' E: Unable to locate package libopencv-flann4.5 E: Couldn't find any package by glob 'libopencv-flann4.5' E: Unable to locate package libopencv-highgui4.5 E: Couldn't find any package by glob 'libopencv-highgui4.5' E: Unable to locate package libopencv-imgcodecs4.5 E: Couldn't find any package by glob 'libopencv-imgcodecs4.5' E: Unable to locate package libopencv-imgproc4.5 E: Couldn't find any package by glob 'libopencv-imgproc4.5' E: Unable to locate package libopencv-ml4.5 E: Couldn't find any package by glob 'libopencv-ml4.5' E: Unable to locate package libopencv-objdetect4.5 E: Couldn't find any package by glob 'libopencv-objdetect4.5' E: Unable to locate package libopencv-photo4.5 E: Couldn't find any package by glob 'libopencv-photo4.5' E: Unable to locate package libopencv-shape4.5 E: Couldn't find any package by glob 'libopencv-shape4.5' E: Unable to locate package libopencv-stitching4.5 E: Couldn't find any package by glob 'libopencv-stitching4.5' E: Unable to locate package libopencv-video4.5 E: Couldn't find any package by glob 'libopencv-video4.5' E: Unable to locate package libopencv-videoio4.5 E: Couldn't find any package by glob 'libopencv-videoio4.5' E: Unable to locate package libproj19 E: Unable to locate package libtesseract4 E: Unable to locate package python3-pil-dbg E: Unable to locate package python3-pil.imagetk-dbg E: Couldn't find any package by glob 'python3-pil.imagetk-dbg' E: Package 'netcat' has no installation candidate
Last edit: 25 Jun 2022 03:31 by tim052.

Please Log in or Create an account to join the conversation.

More
25 Jun 2022 03:33 #245839 by spumco
Yuck, that's no good.

I'm new(ish) at this, too.  Seems like various distributions of Linux, LCNC, python, and the supporting programs (qtvcp, qtpyvcp, etc.) are in a bit of a mess.

My guess is that you want, eventually, LCNC 2.9 and Probe Basic, and maybe don't care so much what linux distribution everything is running on?

Have you tried using the Debian 10 + LCNC 2.8 iso? Or is that a no-go due to hardware incompatibilities and you really need Deb 11, Deb 12, or some other Deb 11 -based distribution?

Please Log in or Create an account to join the conversation.

More
26 Jun 2022 18:57 - 26 Jun 2022 18:58 #245947 by Bari
LCNC 2.9 installed without any issues on Deb11 until a few weeks ago.

"po4a 0.62 in bullseye is too old, it also cannot build our docs
we need 0.66 from bookworm/testing and unstable
it also looks like DEB_BUILD_OPTIONS=parallel=N is no longer honored, so that'll make the build times longer too"

For RIP:
username@debian11:~/dev/rip/src$ make
emc/Submakefile:4: warning: overriding recipe for target '../include/linuxcnc.h'
emc/Submakefile:4: warning: ignoring old recipe for target '../include/linuxcnc.h'
Reading 205/205 dependency files
Done reading dependencies
Reading 230/230 realtime dependency files
Done reading realtime dependencies
You now need to run 'sudo make setuid' in order to run in place with access to hardware.
cd rip
source scripts/rip-environment
you may need to add a line like this one to your ~/.bashrc 
source /home/turboss/Projects/linuxcnc/scripts/rip-environment
RIP works on Deb11 with some changes to the install instructions. I'm building on Sid later. I'll post an update.
Last edit: 26 Jun 2022 18:58 by Bari.
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
28 Jun 2022 08:31 #246063 by Bari
LCNC 2.9 uspace Debian 11 Packages:
repository.qtpyvcp.com/repo/linuxcnc_debs/

These were built back in April of this year.

Please Log in or Create an account to join the conversation.

More
29 Jun 2022 22:07 #246224 by andypugh
po4a 0.66 is now available on the LinuxCNC servers.
andypugh@buster:~$ apt-cache madison po4a
      po4a |     0.66-1 | http://www.linuxcnc.org buster/base amd64 Packages
      po4a |     0.55-1 | http://deb.debian.org/debian buster/main amd64 Packages
      po4a |     0.55-1 | http://deb.debian.org/debian buster/main Sources
andypugh@buster:~$ cat /etc/os-release 
PRETTY_NAME="Debian GNU/Linux 10 (buster)"
NAME="Debian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=debian
HOME_URL="https://www.debian.org/"
SUPPORT_URL="https://www.debian.org/support"
BUG_REPORT_URL="https://bugs.debian.org/"

Please Log in or Create an account to join the conversation.

Moderators: KCJLcvette
Time to create page: 0.086 seconds
Powered by Kunena Forum