Probe basic not fully installing

More
18 Feb 2023 02:51 #264736 by 9183jim
Hi I have tried to install probe basic several times including fresh installs of Linux CNC 2.8.4 Debian 10 Buster PREEMPT RT ISO.
Here is the error i get each time. Error during installation process (com.probebasic.core):
Execution failed (Unexpected exit code: 1): "python -m pip install --user --upgrade git+https://github.com/kcjengr/qtpyvcp.conversational-gcode.git"

I have had a look at the github but i dont see anything that can help me.
I have no idea what my next step from here would be and any help would be appreciated.
Thanks Jim

Please Log in or Create an account to join the conversation.

More
19 Feb 2023 23:40 - 20 Feb 2023 08:09 #264838 by 0x2102
Try and follow this guide:

github.com/joco-nz/lcnc-bullseye-installer

This led me to a working install of LCNC 2.9 with Probe Basic. 
Last edit: 20 Feb 2023 08:09 by 0x2102.

Please Log in or Create an account to join the conversation.

More
25 Feb 2023 10:33 #265309 by 9183jim
Thank you I will give it a try when I can get enough time to follow it carefully 

Please Log in or Create an account to join the conversation.

More
26 Feb 2023 06:32 #265388 by Lcvette

Thank you I will give it a try when I can get enough time to follow it carefully 

this may no longer work as of the latest apt updates or OS installation as python 3.11 is the newest used and it no longer supports system wide installation using pip.  we are working tirelesslly on trying to get debian packages built to make installing with .deb for easy to maintain install method.  with some luck we can slay that dragon in the next couple of days and get put out for download with instructions.  sorry for the inconvenience, its been a doozy of a week for updates in the python3 world..   /o\

Please Log in or Create an account to join the conversation.

More
04 Mar 2023 01:18 #265815 by nwallace
I also have this exact same error during install. Is there a work-around for this? Do I just need to wait until you guys are able to build the deb packages?

Thanks for all the effort in building an maintaining this. It looks sweet and I can't wait to try it out.

Please Log in or Create an account to join the conversation.

More
04 Mar 2023 02:18 #265816 by Lcvette
we are really close on the .deb builds, we thought we had it earlier today but found on a clean system there were some issues where previous testing items had been left behind that were satisfying some requirements and when we tested what we thought was a winner we found those errors.  we have managed to fix all of them but the last one im working on right now is how to package the bebaskai.ttf true type font file.  once that is figured and we can build localy succesfully, Turboss will update the bot and then we will find a place to host the (.deb) files..

just a little more patience.  I will say it is wonderful to just download a files and use a single line for install
albeit there are 3 debs required, and if i don't figure how to pack this ttf into the build package, there may be 4..lol.. 

If anyone out there may know how to help package a ttf, PLEASE come help put me out of my misery!

Chris

Please Log in or Create an account to join the conversation.

More
04 Mar 2023 03:30 #265818 by Lcvette
got it solved!  \o/  so maybe tomorrow we will get the .debs up somewhere after we get the bot updated and building! in the interim if anyone has a blank slate install of debian 12 and would like to test the debs i can send them!

Please Log in or Create an account to join the conversation.

More
13 Mar 2023 08:46 #266536 by jr01
Hello I'm facing the same issues and tryed for days to get Probe Basic running and now i just saw this thread.
Is there any possible workaround? or when can we expexct a worink installing procedure?

Please Log in or Create an account to join the conversation.

More
13 Mar 2023 19:46 #266600 by nwallace
The following user(s) said Thank You: Lcvette

Please Log in or Create an account to join the conversation.

More
13 Mar 2023 20:33 #266605 by Lcvette
going forward installing on Debian 12 Bookworm is the official recommended method for probe basic installation. unless there is a reason you cannot run debian 12 bookworm.  this will be the branch and installation that will be receiving the most attention.  We are trying to resolve a debian 11 installation but it may take some time.  we were hoping to have an easy time of transitioning the latest main branch to be used by the installer script but there are some conflicts.  if they can be resolved we will release an updated debian 11 installation method and if not we will simply remove that option to unconfuse the situation.

Please Log in or Create an account to join the conversation.

Moderators: KCJLcvette
Time to create page: 0.160 seconds
Powered by Kunena Forum