Arduino based USB Pendant for Linuxcnc

More
12 Feb 2017 14:00 #87869 by anda
Hello, I am new to Linuxcnc, and i need some help. I tried to make the arduino pendant but I have a problem. You can see in picture 1(Linuxcnc is not started)

and in picture 2( that's what appear on the lcd when I start linuxcnc). I think it's a connection problem. Any advice? Thank you

Arduino pendant when I start linuxcnc
Attachments:
More
12 Feb 2017 16:34 #87875 by ArcEye
Without a lot more information I can only guess.

At the most basic level, make sure that the #define DEVICE= definition in serialcon2.comp is correct for your board, it needs to be whatever port you used to upload the arduino script arduinopendant.ino

Failing that, you need to attach all your config files (ini and hal), run with DEBUG=7 in your ini file and attach the debug output from stderr and linuxcnc.log
More
13 Feb 2017 16:51 #87916 by ArcEye

Hello Mr ArcEye. I tried a fresh install for arduino pendant, and I got: " Pin 'halui.axis.0-pos-relative' does not exist" .

In custom_postgui.hal I have to put only
"loadusr -W serialcon2
net Xposition halui.axis.0.pos-relative serialcon2.xposition
net Yposition halui.axis.1.pos-relative serialcon2.yposition
net Zposition halui.axis.2.pos-relative serialcon2.zposition" ? Thank you


Please don't send me personal emails, I am not going to answer them

halui.axis.0-pos-relative is a valid pin, but without your config files I am not going to guess whether you have even enabled HALUI
www.linuxcnc.org/docs/devel/html/gui/halui.html
More
15 Feb 2017 17:11 #88005 by anda
Hello. I'm sorry for the personal email. Here are the config files

File Attachment:

File Name: anda.hal
File Size:4 KB

File Attachment:

File Name: anda.ini
File Size:2 KB

File Attachment:

File Name: custom_postgui.hal
File Size:0 KB

File Attachment:

File Name: custom.hal
File Size:0 KB

File Attachment:

File Name: custompanel.xml
File Size:0 KB
More
16 Feb 2017 14:30 #88051 by ArcEye
For starters, you are trying to load the component twice

Once right at the start of adna.hal, before any rt components have been loaded
loadusr -W serialcon2
loadrt trivkins
loadrt [EMCMOT]EMCMOT base_period_nsec=[EMCMOT]BASE_PERIOD servo_period_nsec=[EMCMOT]SERVO_PERIOD num_joints=[TRAJ]AXES
loadrt hal_parport cfg="0 out"
setp parport.0.reset-time 5000
loadrt stepgen step_type=0,0,0
loadrt pwmgen output_type=1

and then again in custom_postgui.hal

It should only be loaded once in custom_postgui.hal, after everything else is loaded.
More
19 Feb 2017 12:28 #88256 by andypugh
It looks to me like the brightness might just be turned up way too high.
Moderators: ArcEye
Time to create page: 0.366 seconds
Powered by Kunena Forum