7i80HD-25 configuration

More
08 Dec 2016 20:17 #83806 by andypugh
andypugh replied the topic: 7i80HD-25 configuration
OK, that's a PWM and encoder firmware for a servo setup, so you will need to flash with a more appropriate firmware.

Do you need any encoders for spindle or handwheels?

A good start is probably to claim that you have a 5i23 using the SVST4_8 firmware to make a config with stepconf.
(and flash the card with Mesaflash using 7i80hd_16_svst4_8.bit as the bitfile)
That will need editing in the HAL file to loadrt hm2_eth rather than hm2_pci, and it will need the IP address of the card adding. (basically, leave the config=".." the same and add board_ip=10.10.10.1 (or whatever)
More
08 Dec 2016 20:21 - 08 Dec 2016 20:29 #83809 by mikikg
mikikg replied the topic: 7i80HD-25 configuration
Great, I will try 7i80hd_25_st18.bit firmware and will report my results.

Thank you all for quick help!

PS: I don't need encoder feedback as servo driver (Xinje) will do all required job and optionally I can handle various error reporting from it which can alert me if for some reason motor can't reach required destination. From my point of view it is open-loop system for motion control.
Last Edit: 08 Dec 2016 20:29 by mikikg.
More
12 Dec 2016 18:10 #83959 by mikikg
mikikg replied the topic: 7i80HD-25 configuration
Hi again,

I have manage to flash Mesa card with "7i80hd_25_st18.bit", then trough PnCConfig configure HAL for 4 axis step/dir generators, then manually added changes in HAL file as proposed in previous posts, all looks fine there but I stuck now on this error:

./my_LinuxCNC_machine.hal:9: parameter or pin 'hm2_5i23.0.watchdog.timeout_ns' not found

I do not have such parameter in HAL file, tried to add it as "setp hm2_5i23.0.watchdog.timeout_ns 1000000" but still got same error.

What can be the problem here?

I have attached to this message my HAL configuration and ERROR output.

File Attachment:

File Name: my_LinuxCN...hine.hal
File Size:10 KB

File Attachment:

File Name: error_1.txt
File Size:61 KB
Attachments:
More
12 Dec 2016 18:32 - 12 Dec 2016 20:16 #83961 by PCW
PCW replied the topic: 7i80HD-25 configuration
try
setp hm2_7i80.0.watchdog.timeout_ns 1000000

(looking at your hal file, you need to do a global replace of 5i23 with 7i80)
Last Edit: 12 Dec 2016 20:16 by PCW.
More
12 Dec 2016 20:19 #83971 by mikikg
mikikg replied the topic: 7i80HD-25 configuration
Something totally strange in my case, everything I try result almost in same error.

For example "config="firmware=hm2/5i23/SVST4_8.BIT", if I put there my firmware or even specify non existing files that do not change anything.

Next, "setp hm2_7i80.0.watchdog.timeout_ns 1000000" (or 5i23) produce same error. If I comment that line, then I got error on "addf hm2_5i23.0.read servo-thread", if I comment that line then I got error on "addf hm2_5i23.0.write" and so on ...
More
12 Dec 2016 20:34 #83973 by PCW
PCW replied the topic: 7i80HD-25 configuration
That's kind of expected since you have a 5i23 configuration file, not a 7i80 configuration file
so the first step is globally replacing all the "5i23"s with "7i80s"

Then the config line needs to be changed ( dropping the firmware=xxxx statement )
More
12 Dec 2016 20:37 #83974 by andypugh
andypugh replied the topic: 7i80HD-25 configuration

PCW wrote: That's kind of expected since you have a 5i23 configuration file, not a 7i80 configuration file
so the first step is globally replacing all the "5i23"s with "7i80s"


To be fair, much as I fully intended to put that step in my instructions above, I clearly forgot to do so.
More
12 Dec 2016 20:43 #83975 by mikikg
mikikg replied the topic: 7i80HD-25 configuration
No luck, again same errors.

Is it possible for someone to give me the simplest HAL configuration for 1 axis, without any other I/O, for my 7i80HD-25 card?
More
12 Dec 2016 20:45 #83976 by PCW
PCW replied the topic: 7i80HD-25 configuration
what errors?
More
12 Dec 2016 20:48 #83977 by mikikg
mikikg replied the topic: 7i80HD-25 configuration
I got this error if that is not commented out:
./my_LinuxCNC_machine.hal:9: parameter or pin 'hm2_5i23.0.watchdog.timeout_ns' not found
Moderators: cmorley
Time to create page: 0.094 seconds
Powered by Kunena Forum