Gmoccapy Bug?

More
14 Jan 2017 11:36 #85740 by newbynobi
newbynobi replied the topic: Gmoccapy Bug?
Hallo Timmert,

please change you HOME = 0 to a smal value away from your home switches or give a HOME_OFFset value.
Otherwise your machine may still be on the mome switch after homing, leading to an error if you try to home again.

I use on my mill both (METRIC!!)
HOME = 10
HOME_OFFSET = -0,5
HOME_SEARCH_VEL = -25
HOME_LATCH_VEL = 3

What error do you get?

Norbert
More
14 Jan 2017 11:39 #85741 by timmert
timmert replied the topic: Gmoccapy Bug?
Hi Norbert
My home offset is working fine never had problems.
I also don't get any error.

The problem is that after I home the machine I go to the MDI screen.
If I home again I can't switch between jog and MDI screen. I can click MDI, but the screen doesn't switch from the jog mode.
Homing is working fine.
More
14 Jan 2017 11:51 #85742 by newbynobi
newbynobi replied the topic: Gmoccapy Bug?
OK,

What release number does the GUI show?
Please start from a terminal and watch for outputs.

I am not able to reproduce that, are you able to make a screen video?
I recommend "RecordMyDesktop" for that purpose.

Norbert
More
14 Jan 2017 11:58 #85743 by timmert
timmert replied the topic: Gmoccapy Bug?
Ok will make a video
More
14 Jan 2017 14:17 #85748 by thor44
thor44 replied the topic: Gmoccapy Bug?
Norbert

I have not tested yet, I am still waiting for someone to help me install the update.

can you help?
More
14 Jan 2017 15:22 - 14 Jan 2017 15:25 #85755 by timmert
timmert replied the topic: Gmoccapy Bug?

thor44 wrote: Norbert

I have not tested yet, I am still waiting for someone to help me install the update.

can you help?

Follow linuxcnc.org/docs/html/getting-started/updating-linuxcnc.html
1.1 updating LinuxCNC

And add one of the master branch (depending on what you're using, Wheezy, Precise etc)
buildbot.linuxcnc.org/
The master = development

if you want to rollback:
Remove the master branch repository from the Synaptic Manager.
Remote LinuxCNC
Add the stable release
Reload
Install

Make sure to backup your config first
Last Edit: 14 Jan 2017 15:25 by timmert.
More
15 Jan 2017 11:25 #85812 by timmert
timmert replied the topic: Gmoccapy Bug?

newbynobi wrote: OK,

What release number does the GUI show?
Please start from a terminal and watch for outputs.

I am not able to reproduce that, are you able to make a screen video?
I recommend "RecordMyDesktop" for that purpose.

Norbert


I start the machine
1. home
2. enter MDI and enter a G30 (doesn't matter which command I enter)
3. home
4. MDI screen doesn't open, have to completely restart lcnc.
More
15 Jan 2017 13:04 - 15 Jan 2017 13:20 #85814 by newbynobi
newbynobi replied the topic: Gmoccapy Bug?
OK, that is strange. I can see, that your system is not getting out of MDI mode, because of the terminal output.
I checked the code as much as possible, but could not find a solution. The only I did not test, is using gmoccapy together with hal-manual Toollchange.

So please do three tests and report:
1. go to settings page and uncheck reload tool on startup (advanced settings)
2. change from hal_manual toolchange to gmoccapy toolchange (you are using the axis one at the moment)
3. after leaving the MDI mode, before homing the second time, just push any of the jog button, does the machine jog?

And please post your complete config folder.

Norbert
Last Edit: 15 Jan 2017 13:20 by newbynobi.
More
15 Jan 2017 13:45 - 15 Jan 2017 16:38 #85816 by timmert
timmert replied the topic: Gmoccapy Bug?
Thanks for the quick reply.
1. Once I uncheck reload tool on startup. It works fine. But that was the reason I updated to the master haha.
2. Changed it to Gmoccapy tool changer. But doesn't solve it.
3. Machine jogs fine

I added my config

File Attachment:

File Name: config.zip
File Size:8 KB
Attachments:
Last Edit: 15 Jan 2017 16:38 by timmert.
More
15 Jan 2017 16:40 #85823 by timmert
timmert replied the topic: Gmoccapy Bug?
Editted my previous post
Tested and configured the gmoccapy tool changer, works.
But the 'reload tool' setting seems to be the problem.
MDI works fine when it's turned off.
Moderators: newbynobi
Time to create page: 0.096 seconds
Powered by Kunena Forum