setting up for Parallel port Tutoral Part 3

More
22 Aug 2016 09:00 #79237 by gmouer
gmouer replied the topic: setting up for Parallel port Tutoral Part 3
Thanks much Sarah ! I can wait for you to post them here, that way all can benefit. The procedures already posted, and files, are for mill and the differences for lathe were not clear to me.

I'm curious, is there a method to run in simulation mode? Without a PP or mesa? Some just want to poke around pathpilot a bit and are not go further.

Thanks again,
George
More
22 Aug 2016 09:11 #79238 by cncbasher
cncbasher replied the topic: setting up for Parallel port Tutoral Part 3
it's not that easy to set up without a mesa card , but once the mods are done , to create a parallel port , then you do have essentialy a sim setup . pathpilot has many checks for certian procedures or order , and will throw you a curve ball , and kick you out the stadium lol .

i'll see if i can get most of this done today
More
22 Aug 2016 12:49 #79247 by gmouer
gmouer replied the topic: setting up for Parallel port Tutoral Part 3
I have a spare 5i25/7i77 for a mill retro that I will start before too long. I could use that 5i25 I suppose to "get me in". I realize it will reflash the 5i25 but I'm pretty sure its just a matter of reflashing it back to 7i77 software.

Right now, I just want to get into pathpilot and surf around a bit on a familiarization tour. I'm helping a newcomer to lcnc get a lathe up under pathpilot and I just might use it for that mill retro I will be doing. Its tough to help someone without being able to have the software running in front of you and the guy I am helping is far away.
More
22 Aug 2016 15:57 - 22 Aug 2016 16:04 #79262 by cncbasher
cncbasher replied the topic: setting up for Parallel port Tutoral Part 3
yes i know , i help many all around the world , but nice to have a working machine at the end , it amazes people , that i can control say a machine in new zealand from here in the UK .

be carefull that you know what software is flashed in the 5i25 to start with , and dont connect the 7i77
follow my tutorials re flashing different bit files , it can send you on a wild chase , if the config files have any error at all

i'd personally put a newcomer on lcnc , and after a learning time swap a hard drive to pathpilot , it's not as easy to fight not only pathpilot
but to not know lcnc , only makes the matter worse in my opinion .
Last Edit: 22 Aug 2016 16:04 by cncbasher.
More
23 Aug 2016 00:12 #79286 by smgvbest
smgvbest replied the topic: setting up for Parallel port Tutoral Part 3
this may be a dumb question but why not use /tmc/configs/tormach_lathe/tormach_lathe_sim.ini for the config.

in my config_file.txt I have
~/tmc/configs/tormach_lathe/tormach_lathe_sim.ini

I've run sim mode without issue

but also
in operator_login find this line
# uncomment next line to force sim mode
#GREPCOUNT="1"
unccomment GREPCOUNT="1" and is says it will run sim mode.
I haven't tried that one since I call /tormach_lathe_sim.ini directly

am I missing something, seems to work fine to me
More
25 Aug 2016 00:49 #79390 by gmouer
gmouer replied the topic: setting up for Parallel port Tutoral Part 3
My goal is just to look around lathe a bit, and later mill also. The PC I have does not have a parallel port. I could use a 5i25 but would rather not risk it just to look around PP. I have no intentions of attempting to use it to operate a machine at this point, just look it over and get familiar with it.

Will a lathe Parallel port config launch ok on a machine without a parallel port?

I think the answer is a stripped down hal and ini file with neither hostmot or the parallel port driver and probably some lines commented out so pathpilot will launch.

George
More
25 Aug 2016 01:41 #79391 by smgvbest
smgvbest replied the topic: setting up for Parallel port Tutoral Part 3
Thats why I say
edit /home/operator/config_file.txt and put in
~/tmc/configs/tormach_lathe/tormach_lathe_sim.ini

That for me puts in into sim mode
I've not had a single problem running in sim mode on my pathpilot

gmouer wrote: My goal is just to look around lathe a bit, and later mill also. The PC I have does not have a parallel port. I could use a 5i25 but would rather not risk it just to look around PP. I have no intentions of attempting to use it to operate a machine at this point, just look it over and get familiar with it.

Will a lathe Parallel port config launch ok on a machine without a parallel port?

I think the answer is a stripped down hal and ini file with neither hostmot or the parallel port driver and probably some lines commented out so pathpilot will launch.

George

More
25 Aug 2016 09:39 #79400 by gmouer
gmouer replied the topic: setting up for Parallel port Tutoral Part 3
That would cover the INI file but what about a HAL file? Its within the HAL file where the interface hardware would be loaded and the cause of a error if neither a parallel port nor mesa board are present.

Every software I have seen thus far requires either a parallel port or a 5i25.
More
25 Aug 2016 21:32 - 25 Aug 2016 21:35 #79448 by smgvbest
smgvbest replied the topic: setting up for Parallel port Tutoral Part 3
The big item missing from the tormach_lathe_sim.ini fie is they do not load the BITFILE0
[HOSTMOT2]
# **** This is for info only ****
# DRIVER0=hm2_pci
# BOARD0=5i25
BITFILE0=mesa/tormach_lathe.bit

but you look at the tormach_lathe_sim.ini file you'll also see it includes the sim hal files
[HAL]
HALUI = halui
HALFILE = tormach_lathe_sim.hal
POSTGUI_SHUTTLEXPRESS_HALFILE = millshuttlexpress.hal
POSTGUI_HALFILE = postgui_tormach_lathe_sim.hal

here's the diffs for the ini file and the HAL files

File Attachment:

File Name: tormach_la...diff.txt
File Size:4 KB


File Attachment:

File Name: tormach_la...diff.txt
File Size:21 KB


File Attachment:

File Name: postgui_to...diff.txt
File Size:2 KB
Attachments:
Last Edit: 25 Aug 2016 21:35 by smgvbest.
More
26 Aug 2016 09:35 #79465 by cncbasher
cncbasher replied the topic: setting up for Parallel port Tutoral Part 3
if you do not have a parallel port on the pc then you'll have problems ,
as the bios will not be loaded either .

you cannot run a lcnc config in pathpilot without modifying . they are similar but not identical.
Moderators: cncbasher
Time to create page: 0.081 seconds
Powered by Kunena Forum