Pathpilot on 5i25 + 7i76 config issues -> can't get past eStop lockout

11 Mar 2017 09:11 - 11 Mar 2017 09:16 #89409 by Dubmfg

So, I spent 10 hours today trying to fight my way past being unable to remove pathpilot from the e-stop condition it seems to be locked in, alas, I'm asking for some help. Here's the basics:

- 5i25 + 7i76 combo - Purchased as a system from someone who was working on doing what I'm doing
- 5i25 is jumpered to be sending 5V to the 7i76
- 7i76 is receiving the 5V (measured good) as well as 12V VField (measured good) through TB1 Pins 1 and 8
- 5i25 has been flashed successfully with 7i76x2 Firmware
- .ini file has been adjusted to point to the right bitfile for 7i76x2.

I used Mesaflash to load the firmwell, as well as have it in the repository spot for loading upon startup. I am unsure of what (if anything) is required of me to do with the and 7i76x2.xml files, help?

Soooooo, I've worked through the .HAL and .ini (attached) many times over. I've tried different pins, using parts of a lathe config known to work (they seemed to have an estop issue as well, although I did not experience any improvement using their files). Currently I only have my X axis stepper driver connected to pins 1-6 of TB2, and a jumper wire from vField to the eStop pin on TB6.

as per my .HAL config, to the best of my understanding GPIO Input 3 (so, pin #4 on TB6) is the eStop connection. I connected this to +12V to emulate the NC connection. This did not fix my issue.

The checkbox in settings for disable limit switches is checked.

I've dumped the pins in Terminal and I can see what I believe to be the pins handled by the 7i76, so I'm assuming its connected correctly. I'm just having a helluva time trying to get everything to work. I feel like I'm so close! So I must plead, can someone hold my hand through this part? I feel like I'm missing something. As far as editing the .ini to match my ballscrews and whathaveyou I'm not so worried, I can handle that. I've just been foiled by an eStop :(.

Thank you!
Last Edit: 11 Mar 2017 09:16 by Dubmfg.
11 Mar 2017 11:35 #89411 by rodw
Hmm, my e-stop is a bit confusing becasue I or it with a torch breakaway sensor on my plasma cutter. From what I am seeing, you are missing the fault-in signal
net external-estop or2.2.in0 <=  hm2_7i76e.0.7i76.0.0.input-00

net torch-breakaway or2.2.in1 <=  hm2_7i76e.0.7i76.0.0.input-06

net remote-estop estop-latch.0.fault-in <=  or2.2.out
net estop-out estop-latch.0.fault-out
11 Mar 2017 14:47 #89419 by PCW
if using a 7I76 for I/O you dont use GPIO (which are RAW FPGA pins on the 5I25s DB25 interface) but rather
7i76 pins (as rodw has illustrated above)

If you want a list of all the 7I76 pins you can run this command when LinuxCNC is running:

halcmd show pin hm2_5i25.0.7i76
The following user(s) said Thank You: Dubmfg
11 Mar 2017 20:15 #89429 by Dubmfg
So my pin call should be: net estop hm2_5i25.0.7i76.0.0--input-00?
11 Mar 2017 20:22 #89430 by PCW
No need to guess

halcmd show pin hm2_5i25.0.7i76

To see a list of 7I76 pins
12 Mar 2017 00:05 #89443 by Dubmfg
I'm able to view the pins on the 7i76 and was able to change output--07 to be true, which in theory should have lit up the bulb I have between it and ground, but it didn't create any change in voltage. Ideas? W1 and W2 are in the left hand position.
12 Mar 2017 00:49 #89447 by PCW
Wrong pin perhaps?

Also note that with the "rising clamp" terminals, you need to tighten a wire in the terminal
to have a reliable connection

What kind of load do you have? a incandescent bulb may have enough surge current to trip the overcurrent shutoff
12 Mar 2017 00:57 #89448 by Dubmfg
My load is a small automotive dash illuminated rocker switch, a very tiny load. Regardless of load, even when there's no connection I don't see the voltage rise when the pin is activated compared to ground via multimeter. I'm poking around in my Hal currently working off a few working .hal files that I've received with no luck.
12 Mar 2017 01:25 #89451 by Dubmfg
I've tried applying power from vfield to pin 1 of TB6 and I'm unable to get its status to change from FALSE to TRUE. It doesn't make sense....
12 Mar 2017 01:29 - 12 Mar 2017 01:29 #89452 by PCW
Are you using "watch" or halmeter? ("show") is not dynamic

Note that pin 1 of TB6 is at the bottom

Also note that you cannot probe the screw terminals on the terminal blocks unless the screws are tight
Last Edit: 12 Mar 2017 01:29 by PCW.
Moderators: cncbasher
Time to create page: 0.196 seconds
Powered by Kunena Forum