Parallel Port Problems

02 Nov 2009 01:26 #1070 by peiboy
peiboy created the topic: Parallel Port Problems
Ok everybody

Here is an issue that has cropped up today that has me stumped.

I have a very sucessfull home-made CNC router that I use EMC2 to control. The computer is a HP Kayak P2 300 with 128 megs of ram - it has a scsi drive. It is essentially an old Engineering Workstation from the mid to late 90's. It works great. (Live cd version was 2.X)

I am running 3 stepper drivers in pulse / direction mode.

Pin 1 is drive enable
Pin 2, 3 are direction pulse x
Pin 4, 5 are direction pulse y
Pin 5, 6 are direction pulse z

I have
pin 10 the x home and limit switch
Pin 11 is y
Pin 12 is z
pin 13 is e-stop
They are all set to sink to ground when closed

pin 18 is ground

The parallel port is setup is ECP mode - and it works flawlessly

Now, here comes the issue

I got a "new" Dimension 220 with a P3 and 256 megs of ram, it too runs scsi, and is much faster. I installed the latest version of the live cd, which is version 2.3.

Now - I set it up exactly the same, everything works except pins 12 and 13 are always reading activated - so no matter what I do, the system thinks I have the z-axis on the limit switch.

Given what I have told you, what do you think my issue is?


Jonathan MacWilliams
02 Nov 2009 12:42 #1076 by BigJohnT
BigJohnT replied the topic: Re:Parallel Port Problems
My guess is your parallel port. Read the footnote at the bottom of this page...

07 Nov 2009 15:37 - 07 Nov 2009 15:39 #1090 by peiboy
peiboy replied the topic: Re:Parallel Port Problems
Thanks John

I have tried all of the suggestions in the EMC2 Parallel port troubleshooting

One thing that really aggravates me is that none of the commands work on my system as installed for example....

loadrt ......... (Pick your command from the manual and insert it here)

Hal_parport .......

Load .......

gives me a "Bash: Command not found"

So - I have a path issue and/or the new version of EMC2 live CD does not install these things that are called in the manual - either way I don't have enough information in order to access the files directly (I don't know where they live in the file structure) and I am so dummied down by winblows I have forgotten how to get half the information I used to know how to get.

I should also mention that I have 2 of these "new" pentium 3's that are identical and both behave the same.

Thanks in advance for your advice.

Last Edit: 07 Nov 2009 15:39 by peiboy.
07 Nov 2009 15:50 #1092 by BigJohnT
BigJohnT replied the topic: Re:Parallel Port Problems
To execute a HAL command in a terminal window you first have to load HAL.

07 Nov 2009 16:55 #1094 by peiboy
peiboy replied the topic: Re:Parallel Port Problems
Ok John

That really clarified things.

Now I got putzing with Hal and I could not force the port to load in "X" mode. I had to default to "out" mode to get it to load.

So i then would try to probe the pins with the text interface - everytime I typed the commands illustrated in that section of the manual it gave me the "WTF are you talking about" error.

In reading the manual I noticed that I could get to the graphical interface through EMC2. Voila- let's do that I think

That got me into my EMC2 INI and Hal files to try to force that port into any mode other than "OUT"

EMC2 choked every time it tried to load in any port mode other than "Out"

Probing the pins without any hook up It still reads the ports as false with or without the 470 ohm resistor.

According to the BIOS I have the ports in EPP mode - do you think I just have 2 bad ports (One on each machine)?


08 Nov 2009 20:36 #1099 by BigJohnT
BigJohnT replied the topic: Re:Parallel Port Problems
I don't know that much about the parallel port except that I have one that only works as "out" and some that work either way. You might do some searching on the wiki... tons of info over there.

Moderators: ArcEye
Time to create page: 0.107 seconds
Powered by Kunena Forum