Asrock Q1900B-ITX

25 May 2015 05:05 #58977 by drummond
Asrock Q1900B-ITX was created by drummond
First post-be kind
Setup MB as above, 4MB of recommended Kingston value RAM in slot DDR3 A1. 60GB Kingston V300 SATA. Stuffed into a Mini-Box M350 case with a Mini-Box PicoPSU-90 for power. Debian Wheezy.

First test was without any changes and showed that the Wheezy install includes a screensaver which defaults to on and also a (separate) power saver which defaults to blanking the screen after~10 minutes. Switched those two guys to "off" and "never" and switched off onboard sound in the bios. Tests were run with 4 glx gears and (initially) with a youtube running and, after test number one a looping video played with VLC . Initial test timed at 20 minutes

test one: sound turned off(bios) screen saver and power saver off (Debian)

servo thread 25694
base thread 23786

test two no change testing new setup with looping video

servo thread 25184
base thread 20942

test three disabled enhanced halt state (C1E) in bios

servo thread 14904
base thread 20810

Now, where to from here? I know about Isolcpus but I would like to do some further work on bios first to see if I can get better numbers. Any suggestions?

25 May 2015 05:30 #58982 by andypugh
Replied by andypugh on topic Asrock Q1900B-ITX

drummond wrote: Now, where to from here?

Start building the system. Those latency numbers are OK.
The following user(s) said Thank You: drummond
25 May 2015 05:49 #58983 by drummond
Replied by drummond on topic Asrock Q1900B-ITX
Thanks, I did find another "howler" which needed some help.

Primary Graphics Adapter defaults to PCI express rather than onboard, since I'm not using a card for graphics I switched it back to onboard, so:

test four Primary Graphics Adapter switched to "onboard"

servo thread 13385
base thread 17999
11 Oct 2017 16:57 #100217 by marlon1337
Replied by marlon1337 on topic Asrock Q1900B-ITX
i know this thread is a little old. But last week i bought an Q1900B-ITX, too and first i had the same jitters as you.
But some small changes wihtin your Bios setup will make this mainboard a very good and low cost linuxcnc controller.
My jitters are :
Servo Thread : 5831
Base Thread : 7492

Got to your Bios to:
Advanced --> CPU Config --> Disable everything beside "No-Execute Memory Protection
Then go to:
Advanced --> Super IO --> Device Mode --> Bi-Directional
--> Change Settings -> IO=378 with every IRQ

This should do a quite decent job. If you still want some more (which is not necessary) than you can switch off every power saving option and put every option wich has an "auto" in it to a fixed value. For example DRAM "auto" to 1.55 V .
The more fixed values, the better.
08 Oct 2018 13:11 - 08 Oct 2018 13:13 #118540 by mane
Replied by mane on topic Asrock Q1900B-ITX
I have the same board with 8GB value ram and onboard graphic card. What Linux Version did you use and was it 64bit or 32bit Version.
My values depend on what kernel i use (rtai or preempt-rt) and (32bit / 64bit). Best case 10000 and worst case 100000 latency.
Last edit: 08 Oct 2018 13:13 by mane. Reason: added info latency
27 Oct 2018 06:06 #119502 by vre
Replied by vre on topic Asrock Q1900B-ITX
Isolcpus 1,2,3
gives in this board huge jitter improvement
Time to create page: 0.124 seconds
Powered by Kunena Forum