problem with the screen

More
11 Sep 2016 11:51 - 11 Sep 2016 11:56 #80332 by finemeca
finemeca created the topic: problem with the screen
Hello,
I have a problem with the screen saver with linux Debain 7.
I use a motherboard:
ASROCK Q1900B-ITX CARTE MERE

Here's what happens:

lien


I did not need to have a cnc machine a screensaver.
Last Edit: 11 Sep 2016 11:56 by finemeca.
More
11 Sep 2016 12:41 #80334 by tommylight
tommylight replied the topic: problem with the screen
Disable the screen saver go to Applications menu>settings>screensaver and you have MODE so choose "disable screen saver" and close.
If this does not fix it, let us know, as from you picture that is a HSync problem, but that can be many things.
Does that happen only after the screen saver?
More
11 Sep 2016 12:41 #80335 by ArcEye
ArcEye replied the topic: problem with the screen
This is a linux question really, but you are dead right, no place for a screensaver on a cnc controller.

You have not said what desktop environment you are running, that will have a bearing.
I seem to recall the distro uses the crappy xfce interface

In which case
www.google.co.uk/search?q=debian+wheezy+...DVV_mRNYjOmwHFiq-gDQ
More
11 Sep 2016 18:19 #80339 by finemeca
finemeca replied the topic: problem with the screen
ok thank you I will try tomorrow
More
10 Jun 2017 07:30 #94384 by smal
smal replied the topic: problem with the screen
After experimenting one week with various concepts of which none actually worked as expected I have found following options in XFCE desktop to disable the screensaver:

Application Menu -> Settings -> Power Manager -> General -> Monitor Power Management -> should be active
Application Menu -> Settings -> Power Manager -> General -> On AC -> Actions -> Put the computer to sleep when inactive -> scroll bar the to left -> Never
Application Menu -> Settings -> Power Manager -> General -> On AC -> Actions -> spin down hard disks -> not active
Application Menu -> Settings -> Power Manager -> General -> On AC -> Monitor -> Put display to sleep when computer is inactive for -> scroll bar to the left -> Never
Application Menu -> Settings -> Power Manager -> General -> On AC -> Monitor -> Switch off diplay when computer is inactive for -> scroll bar to the left -> Never
Application Menu -> Settings -> Power Manager -> General -> On AC -> Monitor -> Reduce Brightness when computer is inactive for -> scroll bar to the left -> Never

How to make autologin:
Open the file /etc/lightdm/lightdm.conf and navigate to line 78 (you can enable line numbers on Leafpad).
It should be saying #autologin-user=.
Remove the # and change it to have your username after (for example: autologin-user=test).

Regards
Simon Mali
The following user(s) said Thank You: tommylight
More
15 Jun 2017 12:51 #94529 by andypugh
andypugh replied the topic: problem with the screen
I found that even all of the above wasn't enough :-(

xset dpms force off

Does the trick. Needs to be in a startup script, though, or it is just temporary.
One good place would be in the "linuxcnc" script, then it is only activated when you are actually using linuxcnc
Moderators: ArcEye
Time to create page: 0.078 seconds
Powered by Kunena Forum