Logitech F310 not showing data

16 Apr 2017 00:17 #91435 by kg2v
Hey Guys and Gals
I've been trying to get my Logitech F310 to work per:

Now here is the fun - I first tried with an el-cheapy gamepad from China - and it worked - for about 10 minutes till the control bit the dust, plus the d-pad (aka the hat) wasn't right, - but anyway

I hook up the F310 in D mode, and setup the configs as above - and yes running less /proc/bus/input/devices DOES give me

I: Bus=0003 Vendor=046d Product=c216 Version=0300
N: Name="Logitech Logitech Dual Action"
P: Phys=usb-0000:00:03.2-2/input0
S: Sysfs=/class/input/input3
H: Handlers=event3 js0
B: EV=b
B: KEY=fff 0 0 0 0 0 0 0 0 0
B: ABS=30027

and I setup a joystick.hal and set up my Halui - remember it WAS working with the cheap Chinese controller

The fun comes in - I SEE NOTHING when I go to monitor the input pins in Axis (no error on startup as if I had it misnamed)

Any clue why I see no data from the gamepad?
I have tried it both with and without the
Once I did that, I then added a file to the folder: /etc/udev/rules.da. I wasn’t sure if I should do that or not, the instructions were you ‘might’ need to do that, so I went ahead and did it anyway. I made a file titled “joystick.rules” with the
following text:

SYSFS{idProduct}==”c216″, SYSFS{idVendor}==”046d”, MODE=”0660″, GROUP=”plugdev”
b. To add a file to the rules.d folder, you need to be sudo, so I created the file with gedit
using: sudo gedit joystick.rules

Anyone care to guess?
19 Apr 2017 16:13 #91647 by andypugh
The HAL needs to look for a new name. Did you change it to "Logitech" from (or example) "Dragonrise"?
19 Apr 2017 17:50 #91659 by kg2v
Replied by kg2v on topic Logitech F310 not showing data
Yep, tried it as both Logitech and Dual (which is what everyone's example does)

Like I said - when I go in, I can see the pins themselves (and if I disconnect the controller, they go away), and I can see the INITIAL values, but when I push any of the buttons/move any of the joysticks, and click to refresh, the VALUES don't change.
AKA Axis is seeing the gamepad, but the values don't change like the did on the cheapy controller (of course clicking to refresh)
I've tested the controller with Windows - and the controller works
19 Apr 2017 17:57 #91661 by andypugh
I had something similar I vaguely recall. I think I had to press a "mode" button on the controller before it would work.
23 Apr 2017 15:47 #91888 by kg2v
Replied by kg2v on topic Logitech F310 not showing data
Finally got down the basement again
Tried all the buttons etc, no go
I'm starting to look at it, and the only thing I can think of is it is reading the pins on the way in, but it isn't tied into one of the threads - Possible? AKA it reads it once, and never again?
25 Apr 2017 16:06 #92067 by andypugh
A userspace component should run automatically.

What you do sometimes see is a suerspace component get as far as creating the pins and setting some values, then crashing/freezing.

You might be able to see an error report from hal_input if you start LinuxCNC from the command-line with the "linuxcnc" command.
Moderators: ArcEye
Time to create page: 0.080 seconds
Powered by Kunena Forum