143 available updates, 0 applied fix?

More
26 Aug 2017 18:55 #98046 by greenbuggy
greenbuggy created the topic: 143 available updates, 0 applied fix?
Fresh LinuxCNC 2.7.11 install using the ISO from the downloads page
Got my Asus USB Wifi NIC installed and once it had internet access it prompted me to install some updates, let it download and install them, it encountered an error about halfway thru and said it couldn't install it.

Now when I start my system up it says "you have 143 available updates" and the red triangle lit up in the top right of the screen. Click it, enter password, it says "downloading updates" for a few seconds and then brings up a window that says "Applied 0 updates" and below it says "there are 143 more updates available". Ok'ing that screen, check/install updates just brings up the exact same prompts and never actually installs any of them.

Is there an easy way to make it start over with these updates or roll back to pre-updated state short of formatting the HDD and doing a clean reinstall?
More
29 Aug 2017 07:57 #98132 by grump
grump replied the topic: 143 available updates, 0 applied fix?
Try
"sudo apt-get update"
"sudo apt -get upgrade"
from a terminal.
More
03 Sep 2017 07:41 #98402 by verticalperformance
verticalperformance replied the topic: 143 available updates, 0 applied fix?
Had the same thing today - just did a clean install of the Wheezy ISO (after 10.04 died, I tried Mint and the GUI is nice, but has some odd missed steps hiccups, even though latency not too different to 10.04) so tried the Wheezy ISO, which again has reasonable latency and no hiccups. Boots up and the xfce desktop is much faster on my old clunker than mint, just not as user friendly

Anyway, I discovered that there is some sort of issue with the iceweasel / mozilla updates, and as they seem to be first in the update list, no updates proceed.
Unticking those two from the update list seems to let all the other updates succeed, leaving me with only those two, which keep failing.

I think this is a Debian issue, which might just go away by itself, but will try the update/upgrade method next time I'm in the shed.
Moderators: ArcEye
Time to create page: 0.063 seconds
Powered by Kunena Forum