Start point too close to probe point

More
21 Oct 2019 23:54 #148504 by danilom
I am having a really strange message when using gcode on one of plasma cutters.

before any pierce there is probing for material zero and like this

G38.2 Z -20 F500.0
G10 L20 P1 Z0

If I want to continue program from any line message is displayed that "Start point too close to probe point" even if the machine is far away and before G38.2 it always lifts in Z

Also G10 L20 P1 Z0 messes up the preview screen and every contour is shifted in Z for probe distance, someone mentioned L2 instead of L20 but that wont set the material at zero it will set the offset to 0, I think it looks the same even with G92 .
Tried wrapping it in oword and checking task which was also mentioned, but that wont work either as it will need numbering o100 o101 o102 etc

Please Log in or Create an account to join the conversation.

More
22 Oct 2019 08:13 #148535 by tommylight
What config are you using ?

Please Log in or Create an account to join the conversation.

More
22 Oct 2019 09:12 #148537 by danilom
Standard config I created my own, and just added thc component config and using gmoccapy plasma screen.

Please Log in or Create an account to join the conversation.

More
22 Oct 2019 11:03 #148538 by danilom
Ok what I am seeing is that I can not continue the program from any line I always get the Radius to end of arc error.

It must be because of the circles are in different Z levels, If I remove G38.2 file runs ok and can be run from any line.

Please Log in or Create an account to join the conversation.

More
23 Oct 2019 06:36 #148587 by danilom
Ok I got Plasmac setup working instead so all this is behind us.

Please Log in or Create an account to join the conversation.

Time to create page: 0.078 seconds
Powered by Kunena Forum