Axis movement stops working - strange behaviour...

More
11 Nov 2009 16:03 #1107 by nils
Hi guys, first of all: I'm a total CNC newbie. The CNC I built for myself was the first I ever saw in real life. My problem has been very confusing for me, so this might all look like ramblings from a mad man:

The problem manifests itself as certain movements just won't work after certain other movements (took me forever to find something consistent). Both gcode and jogging will cause this to happen. I have actually done several successful operations like profiling guitar bodies without any issues, but I first started seeing problems when trying to do image-to-gcode. The CNC wouldn't move in the negative X direction at all. After much testing yesterday I discovered that it's only -X, -Y and +Z directions that will stop working; +X +Y and -Z always works. (Z direction is reversed in pin config, so that probably explains why it's the other direction that fails).

This isn't related to any limits (don't have hardware limits, and aren't even close to the soft limits). Now the really curious part: After careful testing using jog in continuous mode I found that -X will not work if the last Y direction was negative. Same for -Y, which will not work if the last X direction was negative. Simply jogging the X or Y axis in the positive direction will allow the other axis to move in the negative direction. Didn't get to test what actually causes the Z axis to stop&start working, was just happy I found something I was able to consistently rep.

Quitting and restarting Axis will also allow me to move in the direction that wouldn't work. Turning off and on the power for the stepper motor drivers doesn't make any difference, so I'm pretty sure it's a software issue.

When I say that it doesn't move at all, that isn't 100% correct. There is slight movement, probably minimum move (2 degrees) every 5 seconds or something when I try continuous jog in a direction that doesn't work.

Anyone have any idea what this could be? Some misconfiguration on my part?


thanks,
Nils

Please Log in or Create an account to join the conversation.

More
12 Nov 2009 12:00 #1109 by BigJohnT
It sounds like your direction timing is too fast. What drives do you have and what is the direction timings you are using?

www.linuxcnc.org/docview/html//common_St...iagnostics.html#r1_3

John

Please Log in or Create an account to join the conversation.

More
15 Nov 2009 11:21 #1129 by nils
Hi John , thanks for your assistance.

I'm using the 3-axis monster stepper driver kit from Probotix (www.probotix.com/index.php?view=product&product_id=33) which has the ProboStep driver. Step time & step space are at 5us, direction hold and direction setup are 20us.

I tried running the test code on all axes, and they were all dead on when done.

In frustration I went ahead and modified almost every numeric value in the ini and hal files. The only thing that made a difference with my problem was when increasing the partport.0.reset-time value. When I did that the small movement (jerking) I mentioned below happened much more frequently and with more movement. And it turned out (didn't notice this last) that actually all the axes are jerking, not just the one I'm trying to move.

I'm starting to suspect the parallel port in the computer I'm using. I think I'll try and get a hold of another computer and see how that works...

regards,
Nils

Please Log in or Create an account to join the conversation.

More
15 Nov 2009 16:04 - 15 Nov 2009 16:08 #1130 by BigJohnT
Here is a little stepper tester that I threw together.
  1. Put both files in your home directory.
  2. Configure the steptest.hal file to your port for direction and step
  3. Open a terminal window and enter
  4. halrun -I -f steptest.hal
  5. Set a velocity the press jog to see if your stepper moves.

You can change the fast period and other things in the steptest.hal file.

When your done type quit at the halcmd: prompt.

John

File Attachment:

File Name: steptest.zip
File Size:1 KB
Attachments:
Last edit: 15 Nov 2009 16:08 by BigJohnT.

Please Log in or Create an account to join the conversation.

More
23 Apr 2010 03:56 #2656 by flexneck
i have a very similiar problem - certain combinations of moves, when running EMC, will cause a the all 3 axis to "jerk". i am also using Probotix yellow motors and a Probotix controller, running on a (otherwise) solid Ubuntu on a machine clocking latency at around 12000 max.

now i was wondering if you actually =had different results using a different computer, and if your problem was somehow ultimately solved?

Please Log in or Create an account to join the conversation.

More
25 May 2010 07:57 #2994 by nils
Hi

First, sorry for not following up on this. Life got it in the way and I had to put my CNC project on hold. I did however manage to fix my issue.

Well "fix" is probably not the correct word. I just connected the USB cable from the Probotix controller to the computer I was using. (I must admit that I feel kinda stupid saying this). Turns out that the controller needs both parallel and USB connected. I was sure I had read somewhere that the USB was experimental only, but the Probotix guys told me it should be connected at all times.

I think the documentation for the Probotix controller/kits are a bit lacking for those of us that are beginners. As another example: I'm in a 230V country and after searching around for the switch for quite some time I was just about to assume that the power supply was auto-switching. Luckily I decided to screw everything apart and found the switch on the side which was mounted to the chassis. Couldn't find anything in the docs about either placement or existence of this switch.

Anyway, thanks again to BigJohn for always helping out. Hope this helps you, flexneck. Even though I'm a month late... :)

Please Log in or Create an account to join the conversation.

More
25 May 2010 19:55 #3006 by flexneck
interesting. i also "solved" the problem - by getting another 25$ P4 computer. its parallel port seems to be just like the probotix controller wants it. i cant remember if i ever tried it with the USB cable plugged in, but it works fine without it on the "new" computer. when i have a minute i will dig up the other computer and try it again with USB plugged in, which really only will supply power independently of the parallel port - the probotix controller clearly only draws power from USB, the other pins are not being used...so even a little USB wall-wart powersupply should do the same thing. i will report with my findings, just to close this topic once and for all :-)

Please Log in or Create an account to join the conversation.

More
26 May 2010 14:59 #3016 by nils
Great. I'll be replacing the computer myself soon (currently the room my CNC is in is open for all, so I need to get a door and lock in place before putting in something permanent). Hopefully I'll be able to confirm whatever your findings will be. I'm guessing this is a "how much power can the computer supply through the parallel port" issue...

Please Log in or Create an account to join the conversation.

Time to create page: 0.132 seconds
Powered by Kunena Forum