Open file does not work

More
08 Jun 2010 20:42 #3091 by gironymo
Hello there,

today I installed Ubuntu 10.04. I patched the Kernel with the rtai, compiled the kernel and installed it. After that I downloaded the source of emc2 2.4.1. I installed it and it works.

Now I have the problem, that I'm not able to open some file in axis. The default file (axis 2.4/axis) is loaded at start. I can do a reference and the simulation works. But if I would open a file, nothing happens.

If i use tkemc, I can open any file.

Can anybody help me?

Thanks a lot

Markus

Please Log in or Create an account to join the conversation.

More
09 Jun 2010 14:48 #3093 by gironymo
Replied by gironymo on topic Re:Open file does not work
Ok, today i found something strange.

If I start emc as root, then it works fine:
cd /usr/src/emc2-2.4.1/scripts
sudo -s
. emc

If I use not sudo -s, I am not able to open any file in axis.

Please Log in or Create an account to join the conversation.

More
09 Jun 2010 19:17 #3095 by Rick G
Replied by Rick G on topic Re:Open file does not work
Hello,

Are the g-code files you wish to open in the default location ~/emc2/nc_files as specified by PROGRAM_PREFIX = in the ini file? Are they * .ngc files?

Rick G

Please Log in or Create an account to join the conversation.

More
10 Jun 2010 07:02 #3098 by gironymo
Replied by gironymo on topic Re:Open file does not work
Hi Rick,

yes, the files are in the default location. I've tried to open an example-file. I've also tried to open some file which is on the desktop. But it was not a *.ngc. The extension was *.nc

I can use Ubunt 6.06 with EMC2 (installed from the live-cd). At this system I'm able to open this files. But now I want to change to Ubuntu 10.04 (for learning and for working with the newest system).
So I've compiled all myself ... patched the rtapi-kernel, compiled the kernel, compiled emc ...

Everything works fine ... this is the last problem which I can't solve myself

thx, Markus

Please Log in or Create an account to join the conversation.

More
10 Jun 2010 10:22 #3099 by Rick G
Replied by Rick G on topic Re:Open file does not work
Hello,

Try to open a file after you rename it *.ngc

You could also..
In the ini file there is PROGRAM_EXTENSION = .ngc or something like that you can edit it with the file estension you wish to use.

Rick G

Please Log in or Create an account to join the conversation.

More
10 Jun 2010 11:48 #3101 by gironymo
Replied by gironymo on topic Re:Open file does not work
The example files which are in the default path are *.ngc

Please Log in or Create an account to join the conversation.

More
12 Jun 2010 10:23 #3118 by Rick G
Replied by Rick G on topic Re:Open file does not work
Hello Markus,

Unfortunately I am not using 10.04 so have no experience there, If the file and directory permissions are correct I do not know why it is not working properly. Sorry.

Rick G

Please Log in or Create an account to join the conversation.

Time to create page: 0.154 seconds
Powered by Kunena Forum